summaryrefslogtreecommitdiff
path: root/telepathy-glib/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2009-06-09 09:27:57 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2009-06-10 14:37:48 +0100
commitf0743304591969845663ebf3ab7ba57fadd5b85e (patch)
treef1b14f344757b964a94c2e2a2e17b8dcf14be2eb /telepathy-glib/Makefile.am
parent2e184d2d313e9b30a9f81f4cf9376dbe1e4811c3 (diff)
downloadtelepathy-glib-f0743304591969845663ebf3ab7ba57fadd5b85e.tar.gz
Add basic proxies for ChannelDispatchOperation, ChannelRequest
Diffstat (limited to 'telepathy-glib/Makefile.am')
-rw-r--r--telepathy-glib/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/telepathy-glib/Makefile.am b/telepathy-glib/Makefile.am
index 29fd8bae2..6f817c324 100644
--- a/telepathy-glib/Makefile.am
+++ b/telepathy-glib/Makefile.am
@@ -42,6 +42,9 @@ EXTRA_DIST = \
account.xml \
account-manager.xml \
channel.xml \
+ channel-dispatcher.xml \
+ channel-dispatch-operation.xml \
+ channel-request.xml \
connection.xml \
connection-manager.xml \
dbus-daemon.xml \
@@ -123,8 +126,10 @@ tpginclude_HEADERS = \
channel.h \
channel-iface.h \
channel-dispatcher.h \
+ channel-dispatch-operation.h \
channel-factory-iface.h \
channel-manager.h \
+ channel-request.h \
connection.h \
connection-manager.h \
contact.h \
@@ -175,6 +180,8 @@ nodist_libtelepathy_glib_internal_la_SOURCES = \
_gen/tp-cli-account-manager-body.h \
_gen/tp-cli-channel-body.h \
_gen/tp-cli-channel-dispatcher-body.h \
+ _gen/tp-cli-channel-dispatch-operation-body.h \
+ _gen/tp-cli-channel-request-body.h \
_gen/tp-cli-connection-body.h \
_gen/tp-cli-connection-manager-body.h \
_gen/tp-cli-dbus-daemon-body.h \
@@ -185,6 +192,8 @@ nodist_libtelepathy_glib_internal_la_SOURCES = \
_gen/tp-svc-account-manager.c \
_gen/tp-svc-channel.c \
_gen/tp-svc-channel-dispatcher.c \
+ _gen/tp-svc-channel-dispatch-operation.c \
+ _gen/tp-svc-channel-request.c \
_gen/tp-svc-connection.c \
_gen/tp-svc-connection-manager.c \
_gen/tp-svc-generic.c \
@@ -200,6 +209,8 @@ nodist_geninclude_HEADERS = \
_gen/tp-cli-account-manager.h \
_gen/tp-cli-channel.h \
_gen/tp-cli-channel-dispatcher.h \
+ _gen/tp-cli-channel-dispatch-operation.h \
+ _gen/tp-cli-channel-request.h \
_gen/tp-cli-connection.h \
_gen/tp-cli-connection-manager.h \
_gen/tp-cli-dbus-daemon.h \
@@ -210,6 +221,8 @@ nodist_geninclude_HEADERS = \
_gen/tp-svc-account-manager.h \
_gen/tp-svc-channel.h \
_gen/tp-svc-channel-dispatcher.h \
+ _gen/tp-svc-channel-dispatch-operation.h \
+ _gen/tp-svc-channel-request.h \
_gen/tp-svc-connection.h \
_gen/tp-svc-connection-manager.h \
_gen/tp-svc-generic.h \
@@ -246,7 +259,9 @@ libtelepathy_glib_internal_la_SOURCES = \
channel-group.c \
channel-internal.h \
channel-dispatcher.c \
+ channel-dispatch-operation.c \
channel-manager.c \
+ channel-request.c \
connection.c \
connection-internal.h \
connection-handles.c \
@@ -405,6 +420,16 @@ _gen/tp-cli-%-body.h _gen/tp-cli-%.h: _gen/tp-spec-%.xml \
subclass_assert=--subclass-assert=TP_IS_CHANNEL_DISPATCHER; \
maybe_reentrant=--generate-reentrant; \
;; \
+ channel-dispatch-operation) \
+ subclass=--subclass=TpChannelDispatchOperation; \
+ subclass_assert=--subclass-assert=TP_IS_CHANNEL_DISPATCH_OPERATION; \
+ maybe_reentrant=--generate-reentrant; \
+ ;; \
+ channel-request) \
+ subclass=--subclass=TpChannelRequest; \
+ subclass_assert=--subclass-assert=TP_IS_CHANNEL_REQUEST; \
+ maybe_reentrant=--generate-reentrant; \
+ ;; \
connection-manager) \
subclass=--subclass=TpConnectionManager; \
subclass_assert=--subclass-assert=TP_IS_CONNECTION_MANAGER \