summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-01-15 21:09:30 +0000
committerEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-01-26 17:59:01 +0000
commit175244fb67f2f6192a4bf73711ee62870d92d541 (patch)
tree949cc23f0c2cf516488c5f6ea5e8b5eceaec6e15 /tests/Makefile.am
parent70d305f1019d19b103b54755c46c6e5e83085a6d (diff)
downloadtelepathy-glib-175244fb67f2f6192a4bf73711ee62870d92d541.tar.gz
Add tests for TpContactSearchResult
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ec52a9486..8f211a466 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -16,7 +16,8 @@ noinst_PROGRAMS = \
test-intset \
test-signal-connect-object \
test-util \
- test-debug-domain
+ test-debug-domain \
+ test-contact-search-result
TESTS = $(noinst_PROGRAMS) \
all-errors-documented.py
@@ -62,6 +63,14 @@ test_capabilities_LDADD = \
$(top_builddir)/telepathy-glib/libtelepathy-glib-internal.la \
$(GLIB_LIBS)
+# this one uses internal ABI
+test_contact_search_result_SOURCES = \
+ contact-search-result.c
+test_contact_search_result_LDADD = \
+ $(top_builddir)/tests/lib/libtp-glib-tests.la \
+ $(top_builddir)/telepathy-glib/libtelepathy-glib-internal.la \
+ $(GLIB_LIBS)
+
test_dtmf_player_SOURCES = dtmf-player.c
test_dtmf_player_LDADD = \
$(top_builddir)/tests/lib/libtp-glib-tests.la \