summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-01-10 16:43:25 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-01-10 18:12:20 +0000
commit371dfac9776b66cb04c449f4f3e5b5a6ddfa4a5e (patch)
treea6992ad14b52214fc75ad6d06acc36c186f6c9f5 /tests/Makefile.am
parent3e1ed6823ff128c73656239dcf2fe0c4589e9f8a (diff)
downloadtelepathy-glib-371dfac9776b66cb04c449f4f3e5b5a6ddfa4a5e.tar.gz
Check for -Wl,--no-add-needed and add it to AM_LDFLAGS everywhere we compile C
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ec52a9486..d65608f21 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -120,6 +120,9 @@ AM_CPPFLAGS = \
$(GLIB_CFLAGS) \
$(DBUS_CFLAGS) \
$(NULL)
+AM_LDFLAGS = \
+ $(ERROR_LDFLAGS) \
+ $(NULL)
AM_CFLAGS = $(ERROR_CFLAGS)
AM_CXXFLAGS = $(ERROR_CXXFLAGS)