summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2010-10-25 12:26:53 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2010-10-25 12:26:53 +0100
commit6a911f444b8420850ac41cb5892afd105ab740df (patch)
treedb6444e9ef642053c5aa5ace64ee391a560db411 /tests/Makefile.am
parent552b60cea2478d787f482299b9217b010c57bc4d (diff)
downloadtelepathy-glib-6a911f444b8420850ac41cb5892afd105ab740df.tar.gz
fd.o #30730: order tests' and examples' CFLAGS and LIBS consistently
- first, things from this source tree, to make sure we don't use an outdated system-wide-installed copy instead - then, things lowest in the stack, ..., things highest in the stack This is essentially the same as danni's patch for #30791, but applied more widely. Also, correctly use CPPFLAGS instead of CFLAGS for -I, -D etc. which are common to C, C++ or anything else that invokes the preprocessor.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am20
1 files changed, 9 insertions, 11 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2289036a1..d04791249 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -103,21 +103,19 @@ check-local: check-coding-style
LDADD = \
$(top_builddir)/telepathy-glib/libtelepathy-glib.la \
+ $(GLIB_LIBS) \
$(DBUS_LIBS) \
- $(GLIB_LIBS)
+ $(NULL)
-AM_CFLAGS = \
- $(ERROR_CFLAGS) \
- $(DBUS_CFLAGS) \
- $(GLIB_CFLAGS) \
+AM_CPPFLAGS = \
+ -I${top_srcdir} -I${top_builddir} \
-D_TP_IGNORE_DEPRECATIONS \
- $(TP_GLIB_CFLAGS)
-
-AM_CXXFLAGS = \
- $(DBUS_CFLAGS) \
$(GLIB_CFLAGS) \
- -D_TP_IGNORE_DEPRECATIONS \
- $(TP_GLIB_CFLAGS)
+ $(DBUS_CFLAGS) \
+ $(NULL)
+
+AM_CFLAGS = $(ERROR_CFLAGS)
+AM_CXXFLAGS = $(ERROR_CXXFLAGS)
if HAVE_CXX
noinst_PROGRAMS += \