summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2008-12-03 12:57:34 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2008-12-03 12:57:34 +0000
commitb1fa39f2c83b24aa172d8c3d9039d18ebc0173e3 (patch)
tree4e10a90e115c562d60a20e0499a78fe2ddc448c1 /tests/Makefile.am
parentdb2f4e0dc80195cb1f2672adc1cd48381c67cb09 (diff)
downloadtelepathy-glib-b1fa39f2c83b24aa172d8c3d9039d18ebc0173e3.tar.gz
Simplify makefiles and avoid using $(TP_GLIB_LIBS)
Autoconf substitutions in *_LDADD do not generate Makefile dependencies, so using $(TP_GLIB_LIBS) meant that the tests were not automatically rebuilt when telepathy-glib changed. Also, we overlooked the existence of LDADD, which has an effect analogous to AM_CFLAGS and allows a lot of simplification.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 70d78dfdd..4e5c17e12 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -38,28 +38,18 @@ EXTRA_DIST = README
test_asv_SOURCES = \
asv.c
-test_asv_LDADD = \
- $(top_builddir)/telepathy-glib/libtelepathy-glib.la
test_heap_SOURCES = \
test-heap.c
-test_heap_LDADD = \
- $(top_builddir)/telepathy-glib/libtelepathy-glib.la
test_util_SOURCES = \
test-util.c
-test_util_LDADD = \
- $(top_builddir)/telepathy-glib/libtelepathy-glib.la
test_intset_SOURCES = \
test-intset.c
-test_intset_LDADD = \
- $(top_builddir)/telepathy-glib/libtelepathy-glib.la
test_availability_cmp_SOURCES = \
test-availability-cmp.c
-test_availability_cmp_LDADD = \
- $(top_builddir)/telepathy-glib/libtelepathy-glib.la
# this needs to link against the static convenience library so that
# _tp_debug is still visible
@@ -72,6 +62,9 @@ check_c_sources = *.c
include $(top_srcdir)/tools/check-coding-style.mk
check-local: check-coding-style
+LDADD = \
+ $(top_builddir)/telepathy-glib/libtelepathy-glib.la
+
AM_CFLAGS = \
$(ERROR_CFLAGS) \
$(DBUS_CFLAGS) \