summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2009-12-03 14:50:58 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2009-12-03 14:50:58 +0000
commitb415ac35ab5c3ff0c1c71d88f8de77cee4b6db20 (patch)
tree166e187b38b971ebc59fb5fcf215e74795b27d15 /tests/Makefile.am
parent65e15e6091800ec2c37d08e486258d6875af4a34 (diff)
downloadtelepathy-glib-b415ac35ab5c3ff0c1c71d88f8de77cee4b6db20.tar.gz
tests: improve normal and valgrind environments
Normally, run with G_SLICE=debug-blocks (so GLib finds our bugs). Under valgrind, use G_DEBUG=gc-friendly and G_SLICE=always-malloc. Also fix a typo that resulted in check-valgrind not actually valgrinding the non-D-Bus tests (missing '\').
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 90213bc9d..788346c7d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,20 +19,22 @@ TESTS = $(noinst_PROGRAMS) \
TESTS_ENVIRONMENT = \
abs_top_builddir=@abs_top_builddir@ \
abs_top_srcdir=@abs_top_srcdir@ \
- G_DEBUG=fatal_warnings,fatal_criticals \
+ G_SLICE=debug-blocks \
+ G_DEBUG=fatal_warnings,fatal_criticals$(maybe_gc_friendly) \
PYTHONPATH=@abs_top_srcdir@/tools
include $(top_srcdir)/tools/valgrind.mk
VALGRIND_TESTS_ENVIRONMENT = \
- G_SLICE=always-malloc \
$(TESTS_ENVIRONMENT) \
+ G_SLICE=always-malloc \
$(top_builddir)/libtool --mode=execute \
$(VALGRIND) $(VALGRIND_FLAGS)
check-valgrind:
$(MAKE) check-TESTS \
- TESTS='$$(noinst_PROGRAMS)'
+ maybe_gc_friendly=,gc-friendly \
+ TESTS='$$(noinst_PROGRAMS)' \
TESTS_ENVIRONMENT="$(VALGRIND_TESTS_ENVIRONMENT)"
$(MAKE) -C dbus check-valgrind