summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorAlban Crequy <alban.crequy@collabora.co.uk>2011-10-04 16:57:03 +0100
committerAlban Crequy <alban.crequy@collabora.co.uk>2011-11-04 16:44:25 +0000
commite745c29573950efcb7ffd7c0b6184582c4365c05 (patch)
treeb4fe4824eb2e7f9b32863e3ce7c58026708ab2b3 /tests/Makefile.am
parent45b8e51b72b95646ad855807d0b0f9d89737edf1 (diff)
downloadtelepathy-glib-e745c29573950efcb7ffd7c0b6184582c4365c05.tar.gz
tests: add --enable-installed-tests
This configure option makes it possible to install the tests in /usr/lib/telepathy-glib-tests and run them without the sources. The dbus configuration moved to tests/dbus/dbus-installed for the installed tests and is duplicated into tests/dbus/dbus-uninstalled for the uninstalled tests. https://bugs.freedesktop.org/show_bug.cgi?id=41455
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am28
1 files changed, 21 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 88e4fc899..63abac55a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,7 +4,7 @@ SUBDIRS = \
dbus \
tools
-noinst_PROGRAMS = \
+programs_list = \
test-asv \
test-capabilities \
test-availability-cmp \
@@ -17,9 +17,26 @@ noinst_PROGRAMS = \
test-signal-connect-object \
test-util \
test-debug-domain \
- test-contact-search-result
+ test-contact-search-result \
+ $(NULL)
+
+if HAVE_CXX
+programs_list += \
+ test-util-cxx
+endif
-TESTS = $(noinst_PROGRAMS) \
+if ENABLE_INSTALLED_TESTS
+testsdir = @tpglibtestsdir@
+tests_PROGRAMS = $(programs_list)
+tests_DATA = tpglib-tests.list
+else
+noinst_PROGRAMS = $(programs_list)
+endif
+
+tpglib-tests.list:
+ $(AM_V_GEN)echo $(programs_list) > $@
+
+TESTS = $(programs_list) \
all-errors-documented.py
TESTS_ENVIRONMENT = \
@@ -44,7 +61,7 @@ VALGRIND_TESTS_ENVIRONMENT = \
check-valgrind:
$(MAKE) check-TESTS \
maybe_gc_friendly=,gc-friendly \
- TESTS='$$(noinst_PROGRAMS)' \
+ TESTS='$$(programs_list)' \
TESTS_ENVIRONMENT="$(VALGRIND_TESTS_ENVIRONMENT)"
$(MAKE) -C dbus check-valgrind
@@ -137,8 +154,5 @@ AM_CFLAGS = $(ERROR_CFLAGS)
AM_CXXFLAGS = $(ERROR_CXXFLAGS)
if HAVE_CXX
-noinst_PROGRAMS += \
- test-util-cxx
-
test_util_cxx_SOURCES = util-cxx.cpp
endif