summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2009-03-04 16:33:45 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2009-03-04 16:33:45 +0000
commitee7f5ed75812337b7d600c59a59ec2848a75dec3 (patch)
tree0715bd8dd71d6f04c0dab825b7375483617d3635 /tests/Makefile.am
parent41c8ff2615bb7824399236bfb8ed6e35a57de4df (diff)
downloadtelepathy-glib-ee7f5ed75812337b7d600c59a59ec2848a75dec3.tar.gz
tests: use libtool --mode=execute correctly
This turns out to be necessary to valgrind the tests on Debian post-Lenny.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4e5c17e12..705dc93e6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,24 +4,23 @@ SUBDIRS = \
dbus \
tools
-DYNAMIC_TESTS = \
+noinst_PROGRAMS = \
test-asv \
test-availability-cmp \
test-heap \
+ test-internal-debug \
test-intset \
test-util
-STATIC_TESTS = \
- test-internal-debug
-noinst_PROGRAMS = $(DYNAMIC_TESTS) $(STATIC_TESTS)
TESTS = $(noinst_PROGRAMS)
TESTS_ENVIRONMENT = \
+ abs_top_builddir=@abs_top_builddir@ \
G_DEBUG=fatal_warnings,fatal_criticals
VALGRIND_TESTS_ENVIRONMENT = \
G_SLICE=always-malloc \
$(TESTS_ENVIRONMENT) \
- $(top_builddir)/tools/telepathy-glib-env \
+ $(top_builddir)/libtool --mode=execute \
valgrind --tool=memcheck --leak-check=full --show-reachable=yes \
--suppressions=$(top_srcdir)/examples/tp-glib-examples.supp \
--child-silent-after-fork=yes --num-callers=20 --error-exitcode=42 \
@@ -30,8 +29,7 @@ VALGRIND_TESTS_ENVIRONMENT = \
check-valgrind:
$(MAKE) check-TESTS \
- TESTS_ENVIRONMENT="$(VALGRIND_TESTS_ENVIRONMENT)" \
- TESTS="$(STATIC_TESTS) $(DYNAMIC_TESTS:%=.libs/%)"
+ TESTS_ENVIRONMENT="$(VALGRIND_TESTS_ENVIRONMENT)"
$(MAKE) -C dbus check-valgrind
EXTRA_DIST = README