summaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index 16ede12d0..982359646 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -142,6 +142,14 @@ check-local:
echo "$$file missing from telepathy-glib-docs.sgml"; \
err=1; \
fi; \
- done
+ done; \
+ case $(enable_fatal_warnings)/$$err in \
+ (yes/1) \
+ echo "Documentation check failed" >&2; \
+ exit $$err; \
+ ;; \
+ (*) \
+ exit 0; \
+ ;; \
+ esac
endif
-# ... but don't fail on incomplete documentation, this is a stable branch