summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6910edf8a..0fcfc86cc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,9 @@
+SUBDIRS = \
+ . \
+ dbus \
+ tools
+
noinst_PROGRAMS = \
- test-dbus \
test-handle-set \
test-heap \
test-intset \
@@ -8,11 +12,6 @@ noinst_PROGRAMS = \
TESTS = $(noinst_PROGRAMS)
-test_dbus_SOURCES = \
- test-dbus.c
-test_dbus_LDADD = \
- ../telepathy-glib/libtelepathy-glib-internal.la
-
test_handle_set_SOURCES = \
test-intset.c
test_handle_set_LDADD = \
@@ -43,7 +42,9 @@ test_internal_debug_LDADD = \
check_c_sources = *.c
include $(top_srcdir)/tools/check-coding-style.mk
-AM_CFLAGS = $(ERROR_CFLAGS) @DBUS_CFLAGS@ @GLIB_CFLAGS@ @COVERAGE_CFLAGS@ -I.. -I$(srcdir)/..
-AM_LDFLAGS = @DBUS_LIBS@ @GLIB_LIBS@
-
-TESTS_ENVIRONMENT = sh $(top_srcdir)/tools/with-session-bus.sh --session --
+AM_CFLAGS = \
+ $(ERROR_CFLAGS) \
+ $(DBUS_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ $(TP_GLIB_CFLAGS)