summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-12 14:11:17 +0200
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-12 14:35:53 +0200
commit52e3df63bb1f985637a53e73b892f55387043cea (patch)
tree77d8e0d5b33f55f0d2551799417e67cf8bd41285 /tests/Makefile.am
parent8fbc5939d539754f2a6c4d55e847ccca07119728 (diff)
downloadtelepathy-haze-52e3df63bb1f985637a53e73b892f55387043cea.tar.gz
move tests tools to tests/twisted/tools
Other CMs store these files there. https://bugs.freedesktop.org/show_bug.cgi?id=69269
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am29
1 files changed, 0 insertions, 29 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index edb1084..0677b8f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,32 +3,3 @@ SUBDIRS = .
if WANT_TWISTED_TESTS
SUBDIRS += twisted
endif
-
-%.conf: %.conf.in
- $(AM_V_GEN)sed -e "s|[@]abs_top_builddir[@]|@abs_top_builddir@|g" $< > $@
-
-# We don't use the full filename for the .in because > 99 character filenames
-# in tarballs are non-portable (and automake 1.8 doesn't let us build
-# non-archaic tarballs)
-org.freedesktop.Telepathy.ConnectionManager.%.service: %.service.in
- $(AM_V_GEN)sed -e "s|[@]abs_top_builddir[@]|@abs_top_builddir@|g" \
- -e "s|[@]abs_top_srcdir[@]|@abs_top_srcdir@|g" $< > $@
-
-# D-Bus service file for testing
-service_in_files = haze.service.in
-service_files = org.freedesktop.Telepathy.ConnectionManager.haze.service
-
-# D-Bus config file for testing
-conf_in_files = tmp-session-bus.conf.in
-conf_files = $(conf_in_files:.conf.in=.conf)
-
-BUILT_SOURCES = $(service_files) $(conf_files)
-
-EXTRA_DIST = \
- $(service_in_files) \
- $(conf_in_files) \
- exec-with-log.sh
-
-CLEANFILES = \
- $(BUILT_SOURCES) \
- haze-testing.log