summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2009-01-16 09:33:52 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2009-01-16 09:33:52 +0000
commitd5565d5fbc67b08a77ef727e6dde051f7006516f (patch)
treea2fda452589cdf420bb3a1f802836baee63c489d /tests/Makefile.am
parent0ff365deac53284be15006e4e8dbaaa149d31d7d (diff)
downloadtelepathy-haze-d5565d5fbc67b08a77ef727e6dde051f7006516f.tar.gz
Add infrastructure to run tests with Python and Twisted, taken from Gabble
No tests are actually included yet: authentication with hazetest.py doesn't seem to work with libpurple's XMPP implementation.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..89c31e8
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,34 @@
+SUBDIRS = .
+
+if WANT_TWISTED_TESTS
+SUBDIRS += twisted
+endif
+
+%.conf: %.conf.in
+ sed -e "s|[@]abs_top_builddir[@]|@abs_top_builddir@|g" $< > $@
+
+# We don't use the full filename for the .in because > 99 character filenames
+# in tarballs are non-portable (and automake 1.8 doesn't let us build
+# non-archaic tarballs)
+org.freedesktop.Telepathy.ConnectionManager.%.service: %.service.in
+ sed -e "s|[@]abs_top_builddir[@]|@abs_top_builddir@|g" \
+ -e "s|[@]abs_top_srcdir[@]|@abs_top_srcdir@|g" $< > $@
+
+# D-Bus service file for testing
+service_in_files = haze.service.in
+service_files = org.freedesktop.Telepathy.ConnectionManager.haze.service
+
+# D-Bus config file for testing
+conf_in_files = tmp-session-bus.conf.in
+conf_files = $(conf_in_files:.conf.in=.conf)
+
+BUILT_SOURCES = $(service_files) $(conf_files)
+
+EXTRA_DIST = \
+ $(service_in_files) \
+ $(conf_in_files) \
+ exec-with-log.sh
+
+CLEANFILES = \
+ $(BUILT_SOURCES) \
+ haze-testing.log