summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIonut Biru <ibiru@archlinux.org>2011-04-28 04:55:39 -0700
committerWill Thompson <will.thompson@collabora.co.uk>2011-04-28 13:03:46 +0100
commitdefb7f48129979f2541642c089051ae1afffe084 (patch)
treeb25beff897914f15479acc89d50fad12b79b5341 /configure.ac
parentab915ef39abf132cc3676f7f2c24c1a90e759189 (diff)
downloadtelepathy-idle-defb7f48129979f2541642c089051ae1afffe084.tar.gz
use automake python macro
instead of checking for each python binary version. https://bugs.freedesktop.org/show_bug.cgi?id=36624 Signed-off-by: Ionut Biru <ibiru@archlinux.org> Reviewed-by: Will Thompson <will.thompson@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e257e2a..32e1cb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,12 +102,8 @@ AC_CHECK_PROGS([XSLTPROC], [xsltproc])
if test -z "$XSLTPROC"; then
AC_MSG_ERROR([xsltproc (from the libxslt source package) is required])
fi
-PYTHON=
-AC_CHECK_PROGS([PYTHON], [python2.3 python2.4 python2.5 python])
-if test -z "$PYTHON"; then
- AC_MSG_ERROR([Python is required to compile this package])
-fi
+AM_PATH_PYTHON([2.3])
dnl check for a version of python that can run the twisted tests
AC_MSG_CHECKING([for Python with Twisted and IRC protocol support])