summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmanuele Aina <em@nerd.ocracy.org>2007-06-25 10:11:36 +0000
committerEmanuele Aina <em@nerd.ocracy.org>2007-06-25 10:11:36 +0000
commit1fc154436700293ff1c591ce699870ee065df4e3 (patch)
tree54c8987818c8c9ac3e5a1eecdaacb5b475d226b5 /Makefile.am
parent6b69cdbb9d80d729bffecd8a2f235d48c134d394 (diff)
downloadtelepathy-salut-1fc154436700293ff1c591ce699870ee065df4e3.tar.gz
Make the internal lcov copy executable as darcs doesn't store the exec bit
20070625101136-f974e-dab77336d1fdfc3da4fa88c7e983f37190daada9.gz
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8243a922..e54db162 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,6 +15,21 @@ torture:
forever:
cd tests && $(MAKE) forever
+LCOV_EXECUTABLES=scripts/lcov/lcov \
+ scripts/lcov/gendesc \
+ scripts/lcov/genhtml \
+ scripts/lcov/geninfo \
+ scripts/lcov/genpng
+
+EXTRA_DIST=$(LCOV_EXECUTABLES)
+
+.PHONY: always-run
+
+$(LCOV_EXECUTABLES): always-run
+ chmod +x $(srcdir)/$@
+
.PHONY: lcov
+lcov: $(LCOV_EXECUTABLES)
+
include $(top_srcdir)/rules/lcov.mak