summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd.simons@collabora.co.uk>2008-08-20 15:49:36 +0100
committerSjoerd Simons <sjoerd.simons@collabora.co.uk>2008-08-20 15:49:44 +0100
commit4abc76f17949e855ac2551cc35467b0d972bdffb (patch)
tree8c45fab60cd86175236933af1fe9f21d126bb67b /Makefile.am
parent0c4885f02c635f6beea1b77568a0724a3243a954 (diff)
downloadtelepathy-salut-4abc76f17949e855ac2551cc35467b0d972bdffb.tar.gz
Copy git dist-hook from gabble
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9193be04..313cea8e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,10 @@ SUBDIRS = tools extensions lib src data m4 tests docs
dist-hook:
chmod u+w ${distdir}/ChangeLog
- if test -d _darcs; then darcs changes >${distdir}/ChangeLog; fi
+ if test -d ${top_srcdir}/.git; then \
+ git log --stat > ${distdir}/ChangeLog || \
+ git log > ${distdir}/ChangeLog; \
+ fi
valgrind:
cd tests && $(MAKE) valgrind