summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSiraj Razick <siraj.razick@collabora.co.uk>2012-03-12 19:47:22 -0400
committerSiraj Razick <siraj.razick@collabora.co.uk>2012-03-12 20:32:36 -0400
commit1dd6a66ea92477803b6d7959e55707251ba29519 (patch)
treef3fc20d762f88b98774692e1126bafef8d59a6cc /configure.ac
parent5d706cc7571f5c15fbbab8bf0a0577f9876c77cb (diff)
downloadtelepathy-salut-1dd6a66ea92477803b6d7959e55707251ba29519.tar.gz
build: Use gio-windows-2.0 when cross compiling
The current windows build fails since we are unconditionally looking for gio-unix-2.0, when building for windows we should look for gio-windows-2.0, and then export the flags accordingly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9dd9354a..28fd4028 100644
--- a/configure.ac
+++ b/configure.ac
@@ -178,10 +178,18 @@ PKG_CHECK_MODULES(GLIB,
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
+
+if test "$platform" = "win32"; then
+PKG_CHECK_MODULES(GIO_WINDOWS,
+ [gio-windows-2.0])
+AC_SUBST(GIO_WINDOWS_CFLAGS)
+AC_SUBST(GIO_WINDOWS_LIBS)
+else
PKG_CHECK_MODULES(GIO_UNIX,
[gio-unix-2.0])
AC_SUBST(GIO_UNIX_CFLAGS)
AC_SUBST(GIO_UNIX_LIBS)
+fi
GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)