summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-03-23 15:06:00 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-03-26 12:14:16 +0100
commit4b2480d928b3a3083ba21010607239cb8f85a40e (patch)
tree6df700721fd838ec4911b3f1f18904c492a62dad /configure.ac
parente5ff6de77fbd5e02e8db5a7fcd1576fdc98d6343 (diff)
downloadtelepathy-salut-4b2480d928b3a3083ba21010607239cb8f85a40e.tar.gz
Install non-ABI-stable libraries used by plugins to a private directory
Similar to https://bugs.freedesktop.org/show_bug.cgi?id=46417 in Gabble. Reviewed-by: Jonny Lamb <jonny.lamb@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=47774
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f345e8c3..578dbd9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -273,6 +273,15 @@ AC_ARG_ENABLE(submodules,
build_submodules=$enableval,
build_submodules=yes )
+# These must contain "exec" for automake to work right (install-exec,
+# not install-data).
+#
+# Private directory for Wocky and the salut-plugins library
+if test "x$pluginexeclibdir" = x; then
+ pluginexeclibdir='${libdir}/telepathy/salut-0/lib'
+fi
+AC_ARG_VAR([pluginexeclibdir])
+
dnl plugins
AC_ARG_ENABLE(plugins,
AC_HELP_STRING([--disable-plugins],
@@ -317,7 +326,7 @@ fi
# submodule's configure.
prev_ac_configure_args=$ac_configure_args
-ac_configure_args="$ac_configure_args --with-installed-headers=${wocky_install_headers_dir} --enable-shared-suffix=${PACKAGE}-${VERSION}"
+ac_configure_args="$ac_configure_args --with-installed-headers=${wocky_install_headers_dir} --enable-shared-suffix=${PACKAGE}-${VERSION} --libdir=${pluginexeclibdir}"
if test "x$ENABLE_CODING_STYLE_CHECKS" = xyes ; then
ac_configure_args="$ac_configure_args --enable-coding-style-checks"