summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSiraj Razick <siraj.razick@collabora.co.uk>2012-03-03 20:01:39 -0500
committerSiraj Razick <siraj.razick@collabora.co.uk>2012-03-12 19:29:13 -0400
commit4f398f8354d5b786b7f4a199f4c3962778a4c8c4 (patch)
tree547204d29b13507cf14e98b23d1393632175bd48 /configure.ac
parent0dfe7d75b2c01e575ab51e49358fde81fe538603 (diff)
downloadtelepathy-salut-4f398f8354d5b786b7f4a199f4c3962778a4c8c4.tar.gz
build: Introduce libdns_sd backend for --with-backend switch
Check for libdns_sd when configured with backend option "bonjour"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 19 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8b671643..9dd9354a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,13 +205,21 @@ AC_SUBST(TELEPATHY_GLIB_CFLAGS)
AC_SUBST(TELEPATHY_GLIB_LIBS)
dnl check the backend to use
+if test "$platform" = "win32"; then
AC_ARG_WITH(backend,
- AC_HELP_STRING([--with-backend=[avahi/no]],
+ AC_HELP_STRING([--with-backend=[bonjour/no]],
+ [Zeroconf backend to use]),
+ [], [with_backend=bonjour])
+else
+AC_ARG_WITH(backend,
+ AC_HELP_STRING([--with-backend=[avahi/bonjour/no]],
[Zeroconf backend to use]),
[], [with_backend=avahi])
+fi
-AM_CONDITIONAL(USE_BACKEND_DUMMY, [test "x$with_backend" = "xno"])
AM_CONDITIONAL(USE_BACKEND_AVAHI, [test "x$with_backend" = "xavahi"])
+AM_CONDITIONAL(USE_BACKEND_BONJOUR, [test "x$with_backend" = "xbonjour"])
+AM_CONDITIONAL(USE_BACKEND_DUMMY, [test "x$with_backend" = "xno"])
dnl Check for Avahi
if test x$with_backend = xavahi; then
@@ -222,6 +230,15 @@ if test x$with_backend = xavahi; then
AC_SUBST(USE_BACKEND_AVAHI)
fi
+dnl Check for Bonjour Client Library libdns_sd
+if test x$with_backend = xbonjour; then
+ PKG_CHECK_MODULES(BONJOUR, [libdns_sd])
+ AC_DEFINE(USE_BACKEND_BONJOUR, [], [Use Bonjour backend])
+ AC_SUBST(BONJOUR_CFLAGS)
+ AC_SUBST(BONJOUR_LIBS)
+ AC_SUBST(USE_BACKEND_BONJOUR)
+fi
+
if test x$with_backend = xno; then
AC_DEFINE(USE_BACKEND_DUMMY, [], [Use dummy backend])
AC_SUBST(USE_BACKEND_DUMMY)