summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-10 14:00:45 +0200
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-10 14:00:45 +0200
commit81032ced4dbc3dc31d11e6cfd38373866080eec8 (patch)
tree519ff2efe06a258c92e99b05fb35c2fbfb5cd391 /configure.ac
parent53442c61891f0d84a82de3d3107729e4b7f2d178 (diff)
downloadtelepathy-salut-81032ced4dbc3dc31d11e6cfd38373866080eec8.tar.gz
use libsoup versioning macros
I set the dependency on libsoup 2.24 for now as it's the older VERSION macro defined.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 84ce6ae4..a1ac3667 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,9 +253,11 @@ AS_IF([test x$with_backend = xno],
])
dnl Check for libsoup
-PKG_CHECK_MODULES(LIBSOUP, [libsoup-2.4])
+PKG_CHECK_MODULES(LIBSOUP, [libsoup-2.4 >= 2.24])
AC_SUBST(LIBSOUP_CFLAGS)
AC_SUBST(LIBSOUP_LIBS)
+AC_DEFINE([SOUP_VERSION_MIN_REQUIRED], [SOUP_VERSION_2_24], [Ignore post 2.24 deprecations])
+AC_DEFINE([SOUP_VERSION_MAX_ALLOWED], [SOUP_VERSION_2_24], [Prevent post 2.24 APIs])
dnl check for libuuid
PKG_CHECK_MODULES([UUID], [uuid], [HAVE_UUID=yes], [HAVE_UUID=no])