summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Thompson <will.thompson@collabora.co.uk>2011-07-07 15:32:04 +0100
committerWill Thompson <will.thompson@collabora.co.uk>2011-07-07 15:39:12 +0100
commita0490633f7652cc89d1e9c4b67ea89868f98e7b8 (patch)
treed204d664b341b0d580990d28d47a1ae04d8cadd8 /configure.ac
parent10287449e56eb7acb54572948b4ce9aaa0a0cd52 (diff)
downloadtelepathy-salut-a0490633f7652cc89d1e9c4b67ea89868f98e7b8.tar.gz
Propagate -Werror and coding style checks to Wocky
Previously, -Werror was always enabled in lib/ext/wocky, even for releases. So it just failed to distcheck for me, and would make packagers hate us.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e11d14c7..9d3667d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -250,6 +250,18 @@ AM_CONDITIONAL(ENABLE_PLUGIN_API, test x$enable_plugin_api = xyes)
prev_ac_configure_args=$ac_configure_args
ac_configure_args="$ac_configure_args --with-installed-headers=${wocky_install_headers_dir}"
+if test "x$ENABLE_CODING_STYLE_CHECKS" = xyes ; then
+ ac_configure_args+=" --enable-coding-style-checks"
+else
+ ac_configure_args+=" --disable-coding-style-checks"
+fi
+
+if test "x$tp_werror" = xyes && test "x$official_release" = xno; then
+ ac_configure_args+=" --enable-Werror"
+else
+ ac_configure_args+=" --disable-Werror"
+fi
+
prev_top_build_prefix=$ac_top_build_prefix
AX_CONFIG_DIR([lib/ext/wocky])
ac_top_build_prefix=$prev_top_build_prefix