summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-10 16:08:09 +0200
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-11 15:36:39 +0200
commitb25cffc50890b723c84ad53169caabacfabefd16 (patch)
tree56cf0216a8ad8c1e0291d55f4566939edff1f808 /configure.ac
parente395e1a8319477dca990dfb07914d3667cc0c39c (diff)
downloadtelepathy-salut-b25cffc50890b723c84ad53169caabacfabefd16.tar.gz
configure: add AC_ARG_ENABLE(debug)
https://bugs.freedesktop.org/show_bug.cgi?id=69216
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cc964726..6c1f1da5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,10 @@ TP_COMPILER_WARNINGS([ERROR_CFLAGS], [test "x$enable_fatal_warnings" = xyes],
unused-parameter])
AC_SUBST([ERROR_CFLAGS])
+AC_ARG_ENABLE([debug],
+ [AC_HELP_STRING([--disable-debug], [compile without debug code])],
+ [], [enable_debug=yes])
+
AS_IF([test x$enable_debug = xyes],
[AC_DEFINE(ENABLE_DEBUG, [], [Enable debug code])])