summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlvaro Soliverez <alvaro.soliverez@collabora.co.uk>2011-11-02 10:31:17 -0300
committerWill Thompson <will.thompson@collabora.co.uk>2011-11-21 14:49:57 +0000
commitf312040d789a823a66a3c044ceaf7da3064529fc (patch)
tree441c09bc9c189dd24201fdcbb9609188d5540815 /configure.ac
parentb7cfa229c65ecba4d4a5e9e0ea90331e9d5bb269 (diff)
downloadtelepathy-salut-f312040d789a823a66a3c044ceaf7da3064529fc.tar.gz
Support building for Android.
This adds an autogen.sh and configure flag, --disable-submodules, to disable fetching the Wocky submodule (the flag is plural for consistency with other components), adds some missing compiler and linker flags, and adds targets for Androgenizer. Modified from a patch contributed by Derek Foreman. https://bugs.freedesktop.org/show_bug.cgi?id=42515
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c1751ce1..2c2ee9e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,7 +158,8 @@ dnl GTK docs
GTK_DOC_CHECK
dnl Check for Glib
-PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.24, gobject-2.0 >= 2.16, gthread-2.0 >= 2.4])
+PKG_CHECK_MODULES(GLIB,
+ [glib-2.0 >= 2.24, gobject-2.0 >= 2.16, gthread-2.0 >= 2.4, gio-2.0])
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
@@ -204,6 +205,12 @@ else
AC_MSG_WARN([libuuid not found, falling back to generating random IDs])
fi
+AC_ARG_ENABLE(submodules,
+ AS_HELP_STRING([--disable-submodules],
+ [Use system version of Wocky rather than a submodule]),
+ build_submodules=$enableval,
+ build_submodules=yes )
+
dnl plugins
AC_ARG_ENABLE(plugins,
AC_HELP_STRING([--disable-plugins],