summaryrefslogtreecommitdiff
path: root/extensions/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2013-01-04 11:33:43 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-01-04 12:15:20 +0000
commit2a7bb6bef1e5b1abb21103d720af63c3e47cbe74 (patch)
treea117ec46bd556d0ba2cfb5c0544dc6d9b81788da /extensions/Makefile.am
parent3b78a226708b5a5221159fadbef04cd29d48cb54 (diff)
downloadtelepathy-salut-2a7bb6bef1e5b1abb21103d720af63c3e47cbe74.tar.gz
Update libglibcodegen from telepathy-glib master, and add libtpcodegen
This requires the imports in glib-ginterface-gen to be updated too. Sync the entire file. It no longer needs signals-marshal.h to be generated, so drop that. This also introduces more strict checks for extension interfaces, so sync the OLPC interfaces from Gabble master, and add Room_Handle to the list of external types in all.xml.
Diffstat (limited to 'extensions/Makefile.am')
-rw-r--r--extensions/Makefile.am16
1 files changed, 0 insertions, 16 deletions
diff --git a/extensions/Makefile.am b/extensions/Makefile.am
index 8e2e7679..7cb835bf 100644
--- a/extensions/Makefile.am
+++ b/extensions/Makefile.am
@@ -15,9 +15,6 @@ libsalut_extensions_la_SOURCES = \
extensions.h
nodist_libsalut_extensions_la_SOURCES = \
- _gen/signals-marshal.c \
- _gen/signals-marshal.h \
- _gen/signals-marshal.list \
_gen/enums.h \
_gen/gtypes.h \
_gen/gtypes-body.h \
@@ -57,17 +54,6 @@ extensions.html: _gen/all.xml $(tools_dir)/doc-generator.xsl
$(tools_dir)/doc-generator.xsl \
$< > $@
-_gen/signals-marshal.list: _gen/all.xml \
- $(tools_dir)/glib-signals-marshal-gen.py
- $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-signals-marshal-gen.py $< > $@
-
-_gen/signals-marshal.h: _gen/signals-marshal.list Makefile.am
- $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_salut_ext_marshal $< > $@
-
-_gen/signals-marshal.c: _gen/signals-marshal.list Makefile.am
- $(AM_V_GEN){ echo '#include "_gen/signals-marshal.h"' && \
- $(GLIB_GENMARSHAL) --body --prefix=_salut_ext_marshal $< ; } > $@
-
_gen/register-dbus-glib-marshallers-body.h: _gen/all.xml \
$(tools_dir)/glib-client-marshaller-gen.py
$(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-client-marshaller-gen.py $< \
@@ -103,9 +89,7 @@ _gen/interfaces-body.h: _gen/all.xml \
_gen/svc.c _gen/svc.h: _gen/all.xml $(tools_dir)/glib-ginterface-gen.py
$(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-ginterface-gen.py \
--filename=_gen/svc \
- --signal-marshal-prefix=_salut_ext \
--include='<telepathy-glib/dbus.h>' \
- --include='"_gen/signals-marshal.h"' \
--not-implemented-func='tp_dbus_g_method_return_not_implemented' \
--allow-unstable \
$< Salut_Svc_