summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorJonny Lamb <jonny.lamb@collabora.co.uk>2011-02-07 11:49:59 +0000
committerJonny Lamb <jonny.lamb@collabora.co.uk>2011-02-07 13:49:28 +0000
commit6195e787e6fb2c92cebe85ebd815210f0952a2f0 (patch)
treee69fd50e0a624897ea90e7b76c0e60af9f172d61 /plugins/Makefile.am
parentaacd617f299de8836b41383634c452060f0dcf4f (diff)
downloadtelepathy-salut-6195e787e6fb2c92cebe85ebd815210f0952a2f0.tar.gz
plugins: add a test plugin
Signed-off-by: Jonny Lamb <jonny.lamb@collabora.co.uk>
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
new file mode 100644
index 00000000..a28c8f2c
--- /dev/null
+++ b/plugins/Makefile.am
@@ -0,0 +1,32 @@
+plugindir = $(libdir)/telepathy/salut-0
+
+# testing-only plugins
+noinst_LTLIBRARIES = \
+ test.la
+
+installable_plugins =
+ $(NULL)
+
+if ENABLE_PLUGINS
+plugin_LTLIBRARIES = $(installable_plugins)
+else
+# we still compile the plugin (just to make sure it compiles!) but we don't
+# install it
+noinst_LTLIBRARIES += $(installable_plugins)
+endif
+
+AM_LDFLAGS = -module -avoid-version -shared
+
+test_la_SOURCES = \
+ test.c \
+ test.h
+
+# because test.la is not installed, libtool will want to compile it as static
+# despite -shared (a convenience library), unless we also use -rpath
+test_la_LDFLAGS = $(AM_LDFLAGS) -rpath $(plugindir)
+
+AM_CFLAGS = $(ERROR_CFLAGS) \
+ -I $(top_srcdir) -I $(top_builddir) \
+ @GLIB_CFLAGS@ \
+ -I $(top_srcdir)/salut -I $(top_builddir)/salut \
+ -I $(top_srcdir)/plugins