summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlvaro Soliverez <alvaro.soliverez@collabora.co.uk>2012-03-14 19:29:54 -0300
committerOlli Salli <olli.salli@collabora.co.uk>2012-03-15 22:03:10 +0200
commit19539e3418641cd379e80a69d3243db5537e0dc3 (patch)
treeb204e7e8d1838173e38e89dc79e4cb88655b6607 /src/Makefile.am
parent5754bc81e3f94589d91820fe34975dfb63730f28 (diff)
downloadtelepathy-salut-19539e3418641cd379e80a69d3243db5537e0dc3.tar.gz
Move plugin library-specific code from util.c into its own file, to
prevent dependency problems As part of this, a new SalutPluginContactInterface had to be created to access contact capabilities that were needed for the plugin utils. Accessing SalutContact directly would bring most of salut core in, so a GInterface is used, similar to what is done with SalutPluginConnection
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 43dd959a..d4ebb458 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -79,7 +79,6 @@ CORE_SOURCES = \
tubes-channel.c \
util.h \
util.c \
- $(top_srcdir)/salut/util.h \
protocol.c \
$(top_srcdir)/salut/protocol.h \
plugin-loader.c \
@@ -148,9 +147,13 @@ libsalut_plugins_la_LIBADD = \
libsalut_plugins_la_SOURCES = \
$(top_srcdir)/salut/plugin.h \
+ plugin-util.c \
+ $(top_srcdir)/salut/util.h \
plugin.c \
$(top_srcdir)/salut/plugin-connection.h \
plugin-connection.c \
+ $(top_srcdir)/salut/plugin-contact.h \
+ plugin-contact.c \
$(top_srcdir)/salut/capability-set.h \
capability-set.c \
debug.h \