summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSiraj Razick <siraj.razick@collabora.co.uk>2012-02-03 12:36:31 -0500
committerSiraj Razick <siraj.razick@collabora.co.uk>2012-02-17 15:46:51 -0500
commit2d9394fb317626a07105fc91f3a392d357d5f91c (patch)
tree1ae82625ce4d25da1c5d9fb4a23dd6f41fdd8885 /src/Makefile.am
parenta6f77caf370037002d2452e27e2d46feac7360aa (diff)
downloadtelepathy-salut-2d9394fb317626a07105fc91f3a392d357d5f91c.tar.gz
plugins: Introduce SalutPluginConnectionInterface interface
The library defines a new SalutPluginConnectionInterface which will be implemented by SalutConnection. And plugins can use SalutPluginConnection instead of using SalutConnection directly. This helps us to hide SalutConnection symbols in plugins.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e7974ba1..d4f3e12c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -90,6 +90,8 @@ CORE_SOURCES = \
plugin.c \
$(top_srcdir)/salut/connection.h \
$(top_srcdir)/salut/sidecar.h \
+ $(top_srcdir)/salut/plugin-connection.h \
+ plugin-connection.c \
sidecar.c
AVAHI_BACKEND_SOURCES = \