summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSiraj Razick <siraj.razick@collabora.co.uk>2012-02-15 23:12:12 -0500
committerOlli Salli <olli.salli@collabora.co.uk>2012-02-22 20:43:52 +0200
commit83eb3db22091ddbbfd44eeed79290bcd71d4a310 (patch)
tree7b5ff9733d3d0e2c18f4434677d42aa3f1dd719c /src/Makefile.am
parent44cc9454696cf5e3f1d21fc1d51b46500f2f78e5 (diff)
downloadtelepathy-salut-83eb3db22091ddbbfd44eeed79290bcd71d4a310.tar.gz
build: Fix linker errors from libsalut-plugins.dll
The build doesn't output libsalut-plugin.dll since telepathy-glib is and wocky libs are not added to libsalut_plugins_la, and debug.c is not part of the libsalut_plugin_la sources.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7be84120..ee82fa2a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -80,8 +80,6 @@ CORE_SOURCES = \
util.h \
util.c \
$(top_srcdir)/salut/util.h \
- debug.c \
- debug.h \
protocol.c \
$(top_srcdir)/salut/protocol.h \
plugin-loader.c \
@@ -132,6 +130,10 @@ libsalut_plugins_la_LDFLAGS = \
-no-undefined \
-avoid-version
+libsalut_plugins_la_LIBADD = \
+ @TELEPATHY_GLIB_LIBS@ \
+ @WOCKY_LIBS@
+
libsalut_plugins_la_SOURCES = \
$(top_srcdir)/salut/plugin.h \
plugin.c \
@@ -139,6 +141,8 @@ libsalut_plugins_la_SOURCES = \
plugin-connection.c \
$(top_srcdir)/salut/capability-set.h \
capability-set.c \
+ debug.h \
+ debug.c \
$(top_srcdir)/salut/sidecar.h \
sidecar.c