summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSiraj Razick <siraj.razick@collabora.co.uk>2012-03-03 20:43:59 -0500
committerSiraj Razick <siraj.razick@collabora.co.uk>2012-03-12 19:29:29 -0400
commitc2c156817b6fb3ded558e711a90d6cfa0d217bf8 (patch)
tree6883844504ef9cd658a5ee7c06bf0d2947bcad3f /src/Makefile.am
parent4f398f8354d5b786b7f4a199f4c3962778a4c8c4 (diff)
downloadtelepathy-salut-c2c156817b6fb3ded558e711a90d6cfa0d217bf8.tar.gz
build: Adapt Makefile.am to use USE_BACKEND_BONJOUR
Changes required to handle bonjour backend sources in Makefile.am
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am23
1 files changed, 21 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bff37148..f1321d18 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -101,6 +101,8 @@ AVAHI_BACKEND_SOURCES = \
avahi-self.h \
avahi-self.c
+BONJOUR_BACKEND_SOURCES =
+
if ENABLE_OLPC
CORE_SOURCES += \
olpc-activity.h \
@@ -159,6 +161,10 @@ if USE_BACKEND_AVAHI
libsalut_convenience_la_SOURCES += $(AVAHI_BACKEND_SOURCES)
endif
+if USE_BACKEND_BONJOUR
+ libsalut_convenience_la_SOURCES += $(BONJOUR_BACKEND_SOURCES)
+endif
+
write_mgr_file_SOURCES = write-mgr-file.c
write_mgr_file_LDADD = libsalut-convenience.la \
$(top_builddir)/lib/gibber/libgibber.la \
@@ -174,6 +180,7 @@ check_c_sources = \
$(telepathy_salut_SOURCES) \
$(CORE_SOURCES) \
$(AVAHI_BACKEND_SOURCES) \
+ $(BONJOUR_BACKEND_SOURCES) \
$(DUMMY_BACKEND_SOURCES) \
$(libsalut_plugins_la_SOURCES) \
$(write_mgr_file_SOURCES)
@@ -238,10 +245,22 @@ $(top_builddir)/lib/gibber/libgibber.la:
.PHONY: $(top_builddir)/lib/gibber/libgibber.la
-signals-marshal.list: $(CORE_SOURCES) $(AVAHI_BACKEND_SOURCES) $(DUMMY_BACKEND_SOURCES) Makefile.am
+SIGNAL_MARSHAL_SOURCES = \
+ $(CORE_SOURCES) \
+ $(DUMMY_BACKEND_SOURCES)
+
+if USE_BACKEND_AVAHI
+ SIGNAL_MARSHAL_SOURCES += $(AVAHI_BACKEND_SOURCES)
+else
+if USE_BACKEND_BONJOUR
+ SIGNAL_MARSHAL_SOURCES += $(BONJOUR_BACKEND_SOURCES)
+endif
+endif
+
+signals-marshal.list: $(SIGNAL_Marshal_SOURCES) Makefile.am
$(AM_V_GEN)( cd $(srcdir) && \
sed -n -e 's/.*salut_signals_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
- $(CORE_SOURCES) $(AVAHI_BACKEND_SOURCES) $(DUMMY_BACKEND_SOURCES) ) \
+ $(SIGNAL_MARSHAL_SOURCES) ) \
| sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
if cmp -s $@.tmp $@; then \
rm $@.tmp; \