summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2008-04-21 16:48:35 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2008-04-21 16:48:35 +0000
commit82fd790681fff991ac0a151e71288550c1cd8a94 (patch)
treedfa2d51751555d2349f0820f3533867226932d0f /tools/Makefile.am
parent840dc089b307ec92829ec1168d4e49358910c6be (diff)
downloadtelepathy-salut-82fd790681fff991ac0a151e71288550c1cd8a94.tar.gz
Move extensions/tools to tools (consistent with Gabble, telepathy-glib, etc.)
20080421164835-53eee-424948eb2510e98e743a9c2ba68b8985ed9f84de.gz
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 00000000..ac5ad2ec
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,42 @@
+EXTRA_DIST = \
+ c-constants-generator.xsl \
+ c-interfaces-generator.xsl \
+ doc-generator.xsl \
+ genginterface.py \
+ glib-client-marshaller-gen.py \
+ glib-errors-enum-body.xsl \
+ glib-errors-enum-header.xsl \
+ glib-interfaces-generator.xsl \
+ glib-interfaces-body-generator.xsl \
+ glib-ginterface-gen.py \
+ glib-gtypes-generator.py \
+ glib-signals-marshal-gen.py \
+ identity.xsl \
+ libglibcodegen.py \
+ ls-interfaces.xsl \
+ make-all-async.xsl \
+ spec-to-introspect.xsl \
+ update-spec-gen-am.sh
+
+glib-client-marshaller-gen.py: libglibcodegen.py
+ touch $@
+glib-ginterface-gen.py: libglibcodegen.py
+ touch $@
+glib-gtypes-generator.py: libglibcodegen.py
+ touch $@
+glib-signals-marshal-gen.py: libglibcodegen.py
+ touch $@
+
+glib-interfaces-generator.xsl: c-interfaces-generator.xsl
+ touch $@
+glib-interfaces-body-generator.xsl: c-interfaces-generator.xsl
+ touch $@
+
+TELEPATHY_GLIB_SRCDIR = $(top_srcdir)/../telepathy-glib
+maintainer-update-from-telepathy-glib:
+ set -e && cd $(srcdir) && \
+ for x in $(EXTRA_DIST); do \
+ if test -f $(TELEPATHY_GLIB_SRCDIR)/tools/$$x; then \
+ cp $(TELEPATHY_GLIB_SRCDIR)/tools/$$x $$x; \
+ fi; \
+ done