summaryrefslogtreecommitdiff
path: root/tp/Makefile.PL
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2013-09-26 23:06:02 +0000
committer <>2015-02-03 11:56:22 +0000
commite0b511b834f3529395df67126a7314097c2cf97e (patch)
tree89945ae53183ab2acdc61659c8b0b3e57e4a1f3a /tp/Makefile.PL
parent2d8ae7b161658c4a589172db0072fc99f76fa979 (diff)
downloadtexinfo-tarball-master.tar.gz
Imported from /home/lorry/working-area/delta_texinfo-tarball/texinfo-5.2.tar.xz.HEADtexinfo-5.2master
Diffstat (limited to 'tp/Makefile.PL')
-rw-r--r--tp/Makefile.PL40
1 files changed, 40 insertions, 0 deletions
diff --git a/tp/Makefile.PL b/tp/Makefile.PL
new file mode 100644
index 0000000..ab3b297
--- /dev/null
+++ b/tp/Makefile.PL
@@ -0,0 +1,40 @@
+use 5.00405;
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ NAME => 'Texinfo',
+ VERSION_FROM => 'Texinfo/Parser.pm', # finds $VERSION
+ ABSTRACT => 'Texinfo Parser and Converters',
+ PREREQ_PM => {"Encode" => 0,
+ "Data::Dumper" => 0,
+ "File::Spec" => 0,
+ "Config" => 0,
+ "Carp" => 0,
+ "Unicode::Normalize" => 0,
+ "File::Basename" => 0,
+ "File::Copy" => 0,
+ "Getopt::Long" => 0,
+ "Unicode::EastAsianWidth" => 0,
+ "Text::Unidecode" => 0,
+ "Locale::Messages" => 0,
+ },
+ BUILD_REQUIRES => {"Data::Compare" => 0,
+ "Test::Deep" => 0,
+ "Test::More" => "0.88",
+ "Storable" => 0,
+ },
+ PMLIBDIRS => [ 'Texinfo', 'LocaleData', 'DebugTexinfo' ],
+ EXE_FILES => [ 'texi2any' ],
+ ($] >= 5.005 ? ## Add these new keywords supported since 5.005
+ (
+ AUTHOR => 'Patrice Dumas <pertusus@free.fr>') : ()),
+);
+
+#package MY;
+#sub test
+#{
+# my $inherited = shift->SUPER::test(@_);
+# print STDERR "|$inherited|\n";
+# $inherited;
+#}