summaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am70
1 files changed, 38 insertions, 32 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index fec2df9..6d960d4 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -1,7 +1,10 @@
-# $Id: Makefile.am,v 1.34 2008/03/25 10:51:20 akim Exp $
+# $Id: Makefile.am 5191 2013-02-23 00:11:18Z karl $
# Makefile.am for texinfo/util.
# Run automake in .. to produce Makefile.in from this.
#
+# Copyright 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013
+# Free Software Foundation, Inc.
+#
# This file is free software; as a special exception the author gives
# unlimited permission to copy and/or distribute it, with or without
# modifications, as long as this notice is preserved.
@@ -12,51 +15,54 @@
bin_PROGRAMS = texindex
bin_SCRIPTS = texi2dvi texi2pdf pdftexi2dvi
+nodist_noinst_SCRIPTS = txixml2texi
+
+w32_bat = makeinfo.bat pod2texi.bat texi2any.bat
+if HOST_IS_WINDOWS
+ bin_SCRIPTS += $(w32_bat)
+endif
# for auctex.
pdftexi2dvi: texi2pdf
cp -f $(srcdir)/texi2pdf $@
+txixml2texi: txixml2texi.pl Makefile
+ sed -e 's,[@]datadir[@],$(datadir),g' \
+ -e 's,[@]PACKAGE[@],$(PACKAGE),g' \
+ -e 's,[@]USE_EXTERNAL_LIBINTL[@],$(USE_EXTERNAL_LIBINTL),g' \
+ -e 's,[@]USE_EXTERNAL_EASTASIANWIDTH[@],$(USE_EXTERNAL_EASTASIANWIDTH),g' \
+ -e 's,[@]USE_EXTERNAL_UNIDECODE[@],$(USE_EXTERNAL_UNIDECODE),g' \
+ -e '1 s,/usr/bin/env perl,$(PERL),g' \
+ $(srcdir)/txixml2texi.pl >$@
+ chmod a+x $@
+
localedir = $(datadir)/locale
AM_CPPFLAGS = \
-I$(top_srcdir) \
-I$(top_srcdir)/gnulib/lib \
-I$(top_builddir)/gnulib/lib \
-DLOCALEDIR=\"$(localedir)\"
-LDADD = ../lib/libtxi.a $(top_builddir)/gnulib/lib/libgnu.a $(LIBINTL)
+LDADD = $(top_builddir)/gnulib/lib/libgnu.a $(LIBINTL)
-dist_pkgdata_DATA = texinfo.dtd texinfo.xsl
-pkgdata_DATA = texinfo.cat
+dist_pkgdata_DATA = htmlxref.cnf texinfo.dtd #texinfo.cat
-# we don't actually use version.texi in the rule, but it's one way of
-# noticing when the version changes.
-texinfo.cat: texinfo-cat.in $(top_srcdir)/doc/version.texi
- sed 's/__VERSION__/@VERSION@/g' $(srcdir)/texinfo-cat.in >$@
+# This fails distcheck:
+#texinfo.cat: texinfo-cat.in Makefile
+# sed 's/__VERSION__/$(TEXINFO_DTD_VERSION)/g' $(srcdir)/texinfo-cat.in >$@
+# used to be:
+#texinfo.cat: texinfo-cat.in $(top_srcdir)/doc/version.texi
+# sed 's/__VERSION__/@VERSION@/g' $(srcdir)/texinfo-cat.in >$@
+# Let's try just getting rid of it; not aware of its being used.
# Most of these are for fun. The only official/installed ones are the
# *texi2* scripts.
#
-EXTRA_DIST = README deref.c dir-example fix-info-dir fixfonts \
- fixref.gawk gdoc gen-dir-node gendocs.sh gendocs_template infosrch \
- install-info-html outline.gawk pdftexi2dvi \
- prepinfo.awk tex3patch texi-docstring-magic.el texi2dvi texi2pdf txitextest \
- $(dist_pkgdata_DATA) texinfo-cat.in
-CLEANFILES = $(pkgdata_DATA)
-
-
-# Let's not stress people's TeX installations, etc.
-if MAINTAINER_MODE
-TESTS = \
-bibtex.test \
-dvipdf.test \
-latex2html.test \
-local.test \
-texi2dvi.test
-
-EXTRA_DIST += $(TESTS)
-
-# Each test case depends on defs.
-check_SCRIPTS = defs
-distclean-local:
- -rm -rf testSubDir
-endif
+EXTRA_DIST = README detexinfo dir-example \
+ gendocs.sh gendocs_template \
+ pdftexi2dvi \
+ texi2dvi texi2pdf \
+ $(dist_pkgdata_DATA) texinfo-cat.in texi-elements-by-size \
+ texi2html txixml2texi.pl $(w32_bat) \
+ tests
+
+DISTCLEANFILES = txixml2texi