summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsukeg@gmail.com>2015-05-09 18:33:42 +0900
committerRoger Meier <roger@apache.org>2015-05-10 18:25:56 +0200
commit03f0e18fcb423e165ee05757ba449efb3e672dd1 (patch)
tree847850555238e0a4b647125ebd12c4039d8be0ba /Makefile.am
parent72f8809290a943b12ff7f2cb9395c6ba3506736a (diff)
downloadthrift-03f0e18fcb423e165ee05757ba449efb3e672dd1.tar.gz
THRIFT-3133 Allow "make cross" and "make precross" to run without building all languages
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index d0c813b7f..e6a965a21 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,8 +43,17 @@ precross-%: all
precross: all precross-test precross-lib
# TODO: generate --server and --client switches from "--with(out)-..." build flags
+
+
+empty :=
+space := $(empty) $(empty)
+comma := ,
+
+CROSS_LANGS = @MAYBE_CPP@ @MAYBE_C_GLIB@ @MAYBE_JAVA@ @MAYBE_CSHARP@ @MAYBE_PYTHON@ @MAYBE_RUBY@ @MAYBE_HASKELL@ @MAYBE_PERL@ @MAYBE_PHP@ @MAYBE_GO@ @MAYBE_NODEJS@
+CROSS_LANGS_COMMA_SEPARATED = $(subst $(space),$(comma),$(CROSS_LANGS))
+
cross: precross
- $(PYTHON) test/test.py -s
+ $(PYTHON) test/test.py -s --server $(CROSS_LANGS_COMMA_SEPARATED) --client $(CROSS_LANGS_COMMA_SEPARATED)
TIMES = 1 2 3
fail: precross
@@ -72,10 +81,6 @@ codespell_skip_files = \
rebar \
thrift
-empty :=
-space := $(empty) $(empty)
-comma := ,
-
skipped_files = $(subst $(space),$(comma),$(codespell_skip_files))
style-local: