summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsuke@apache.org>2016-09-04 15:33:40 +0900
committerNobuaki Sukegawa <nsuke@apache.org>2016-09-04 21:13:40 +0900
commit2c64bddc0085de94b01d00bc0e98615562f631d7 (patch)
treefffd8ba394a753a974d749009ae968b32fae4e8a /Makefile.am
parent93fb7eadd093e561e3c7122dc9eb084ca033047d (diff)
downloadthrift-2c64bddc0085de94b01d00bc0e98615562f631d7.tar.gz
THRIFT-3918 Run subset of make cross
This closes #1079
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 10fe49a6c..38dd8c9d6 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,15 +56,18 @@ CROSS_PY=$(PYTHON)
endif
if WITH_PYTHON
-cross: precross
+crossfeature: precross
$(CROSS_PY) test/test.py --retry-count 3 --features .* --skip-known-failures --server $(CROSS_LANGS_COMMA_SEPARATED)
- $(CROSS_PY) test/test.py --retry-count 3 --skip-known-failures --server $(CROSS_LANGS_COMMA_SEPARATED) --client $(CROSS_LANGS_COMMA_SEPARATED)
else
# feature test needs python build
-cross: precross
- $(CROSS_PY) test/test.py -s --server $(CROSS_LANGS_COMMA_SEPARATED) --client $(CROSS_LANGS_COMMA_SEPARATED)
+crossfeature:
endif
+cross-%: precross crossfeature
+ $(CROSS_PY) test/test.py --retry-count 3 --skip-known-failures --server $(CROSS_LANGS_COMMA_SEPARATED) --client $(CROSS_LANGS_COMMA_SEPARATED) --regex "$*"
+
+cross: cross-.*
+
TIMES = 1 2 3
fail: precross
$(CROSS_PY) test/test.py || true