summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsuke@apache.org>2016-01-24 01:34:29 +0900
committerNobuaki Sukegawa <nsuke@apache.org>2016-01-24 03:44:26 +0900
commit5e432ec37b3c9db3a4534f6acdea12c74d42455e (patch)
treeaa4fdf42807669ccd3f8a5b1fc7d064de00eeb08 /Makefile.am
parentccd998a04e8b82a56b1788aa13167e84aa2126d1 (diff)
downloadthrift-5e432ec37b3c9db3a4534f6acdea12c74d42455e.tar.gz
THRIFT-3579 Introduce retry to make cross
This closes #817
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ed400d5b..46e7d4fd8 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,8 +57,8 @@ endif
if WITH_PYTHON
cross: precross
- $(CROSS_PY) test/test.py -F.* -s --server $(CROSS_LANGS_COMMA_SEPARATED)
- $(CROSS_PY) test/test.py -s --server $(CROSS_LANGS_COMMA_SEPARATED) --client $(CROSS_LANGS_COMMA_SEPARATED)
+ $(CROSS_PY) test/test.py --retry-count 3 --features .* --skip-known-failures --server $(CROSS_LANGS_COMMA_SEPARATED)
+ $(CROSS_PY) test/test.py --retry-count 3 --skip-known-failures --server $(CROSS_LANGS_COMMA_SEPARATED) --client $(CROSS_LANGS_COMMA_SEPARATED)
else
# feature test needs python build
cross: precross