summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames E. King III <jking@apache.org>2019-01-24 17:45:07 -0500
committerJames E. King III <jking@apache.org>2019-01-25 23:33:54 -0500
commitb96c43892a9e89dfa61834505bb25357e80287da (patch)
tree02bbf30d80e6f6ef8c76bc67ad20b90331b6de9d /Makefile.am
parent8935c98046dbbdd36ede73c1525f1be9df8da5cd (diff)
downloadthrift-b96c43892a9e89dfa61834505bb25357e80287da.tar.gz
THRIFT-4717: fix up make clean with autoconf
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am50
1 files changed, 42 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index addfa0cfb..104d3705a 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,8 +37,39 @@ if WITH_TUTORIAL
SUBDIRS += tutorial
endif
+clean-local:
+ $(RM) -r vendor/
+
+distclean-local:
+ $(RM) -r .dub/
+ $(RM) -r autom4te.cache/
+
+CLEANFILES = \
+ composer.lock \
+ dub.selections.json
+
+DISTCLEANFILES = \
+ Makefile \
+ Makefile.in \
+ apache-thrift-test-library \
+ autoscan.log \
+ compile \
+ config.guess \
+ config.hin \
+ config.hin~ \
+ config.log \
+ config.status \
+ config.sub \
+ configure \
+ configure.scan \
+ debcomp \
+ install-sh \
+ ltmain.sh \
+ missing \
+ ylwrap
+
dist-hook:
- find $(distdir) -type f \( -iname ".DS_Store" -or -iname "._*" -or -iname ".gitignore" \) | xargs rm -rf
+ find $(distdir) -type f \( -iname ".DS_Store" -or -iname "._*" -or -iname ".gitignore" \) | xargs rm -f
find $(distdir) -type d \( -iname ".deps" -or -iname ".libs" \) | xargs rm -rf
find $(distdir) -type d \( -iname ".svn" -or -iname ".git" \) | xargs rm -rf
@@ -109,27 +140,30 @@ style-local:
EXTRA_DIST = \
.clang-format \
+ .dockerignore \
.editorconfig \
.travis.yml \
.rustfmt.toml \
- .dockerignore \
+ ApacheThrift.nuspec \
appveyor.yml \
+ bootstrap.sh \
bower.json \
build \
- bootstrap.sh \
- cleanup.sh \
+ CHANGES.md \
CMakeLists.txt \
composer.json \
contrib \
CONTRIBUTING.md \
debian \
- doc \
doap.rdf \
- package.json \
- sonar-project.properties \
+ doc \
+ dub.json \
+ jitpack.yml \
LANGUAGES.md \
LICENSE \
- CHANGES.md \
NOTICE \
+ package.json \
+ phpcs.xml.dist \
README.md \
+ sonar-project.properties \
Thrift.podspec