summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2015-04-11 13:12:35 +0200
committerRoger Meier <roger@apache.org>2015-04-11 13:15:13 +0200
commitbb23eadca16f18afaee8e7f69c02f3456358cc6b (patch)
treeb918c35a6ac7dc6a2e88f58f812262c1b54eefd1 /Makefile.am
parent86f7350f90c7432c9415cb43d003ff7e6385c258 (diff)
downloadthrift-bb23eadca16f18afaee8e7f69c02f3456358cc6b.tar.gz
THRIFT-2946 Enhance usability of cross test framework
introduce *make fail* to update known failures
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 65dfe9dbf..5b60c5f5c 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,7 +44,11 @@ precross: all precross-test precross-lib
# TODO: generate --server and --client switches from "--with(out)-..." build flags
cross: precross
- python test/test.py -s
+ $(PYTHON) test/test.py -s
+
+fail: precross
+ $(PYTHON) test/test.py
+ $(PYTHON) test/test.py --update-expected-failures=overwrite
codespell_skip_files = \
*.jar \