summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authornsrtvwls <oakjumper@gmail.com>2018-09-28 08:11:21 -0700
committerJames E. King III <jking@apache.org>2018-09-28 11:11:21 -0400
commit014f53f6582fbae8146ae291d471382016091a06 (patch)
treeebd77be07d6be35c8c840278688bb2fee0a94c1a /compiler/cpp/CMakeLists.txt
parentc64389a194fe1516fef5830151dfb8b35f6c6bb2 (diff)
downloadthrift-014f53f6582fbae8146ae291d471382016091a06.tar.gz
THRIFT-4496: python specific list of keywords for python generator (#1567)
Client: py
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index 5da28aad4..e61887704 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -62,6 +62,9 @@ set(thrift-compiler_SOURCES
src/thrift/audit/t_audit.cpp
)
+set(thrift_compiler_LANGS
+)
+
# This macro adds an option THRIFT_COMPILER_${NAME}
# that allows enabling or disabling certain languages
macro(THRIFT_ADD_COMPILER name description initial)
@@ -70,6 +73,7 @@ macro(THRIFT_ADD_COMPILER name description initial)
option(${enabler} ${description} ${initial})
if(${enabler})
list(APPEND thrift-compiler_SOURCES ${src})
+ list(APPEND thrift_compiler_LANGS ${name})
endif()
endmacro()