summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2014-08-17 22:24:30 +0200
committerRoger Meier <roger@apache.org>2014-08-17 22:24:30 +0200
commit311f7157a2dc5285b027cbf0bc517e9e741de687 (patch)
treefa6328c95a0ceffe9968a9bfc1f9ff92a499d674 /compiler/cpp/CMakeLists.txt
parent7191bc99fe3de1027f7fab21232d5bc6ed1d5db5 (diff)
downloadthrift-311f7157a2dc5285b027cbf0bc517e9e741de687.tar.gz
THRIFT-2571 Simplify cross compilation using CMake
fix CMake build and update README.md
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index 43c37cc41..e98adb719 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -149,6 +149,11 @@ target_link_libraries(thrift libparse)
install(TARGETS thrift DESTINATION bin)
+# mingw32 does not support c++0x features
+if(NOT CMAKE_SYSTEM_NAME STREQUAL "Windows")
+set(CMAKE_CXX_FLAGS "-std=c++0x")
+endif()
+
# create a Distribution Package for the Apache Thrift Compiler
set(CPACK_PACKAGE_NAME "Apache Thrift")
set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "Apache Thrift Compiler")