summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorStig Bakken <stig@zedge.net>2016-02-12 16:33:12 +0100
committerNobuaki Sukegawa <nsuke@apache.org>2016-02-13 23:12:34 +0900
commit41e8cbf6866bf9b8ec6d5bbc157a1fb970d8c3cc (patch)
treeb59add96bf4f0eb75dadec801afc96adbba7a325 /compiler/cpp/CMakeLists.txt
parentac06704a0c62df9ca03782cb05b0f8cc05387a45 (diff)
downloadthrift-41e8cbf6866bf9b8ec6d5bbc157a1fb970d8c3cc.tar.gz
THRIFT-3617 cmake: include `gv` and `xml` generators in build
Client: Build (Compiler) Patch: Stig Bakken This closes #851
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index 94b3c1902..2fdc80009 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -122,6 +122,8 @@ THRIFT_ADD_COMPILER(delphi "Enable compiler for Delphi" ON)
THRIFT_ADD_COMPILER(go "Enable compiler for Go" ON)
THRIFT_ADD_COMPILER(d "Enable compiler for D" ON)
THRIFT_ADD_COMPILER(lua "Enable compiler for Lua" ON)
+THRIFT_ADD_COMPILER(gv "Enable compiler for GraphViz" ON)
+THRIFT_ADD_COMPILER(xml "Enable compiler for XML" ON)
# Thrift is looking for include files in the src directory
# we also add the current binary directory for generated files