summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorJiayu Liu <jiayu.liu@airbnb.com>2022-04-06 16:49:09 +0800
committerJens Geyer <jensg@apache.org>2022-04-20 23:49:33 +0200
commit49b2d6b888a2a96fc0948da81a779a90b4624170 (patch)
tree11b532385bcf72e8ea1188ed489de0c905164a42 /compiler/cpp/CMakeLists.txt
parenteac5103f8204021f7b5436001319c2b17ed5644f (diff)
downloadthrift-49b2d6b888a2a96fc0948da81a779a90b4624170.tar.gz
THRIFT-5548: add kotlin code gen
Client: kotlin Patch: Jiayu Liu This closes #2556
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index 739924a43..717b645ba 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -87,6 +87,7 @@ THRIFT_ADD_COMPILER(java "Enable compiler for Java" ON)
THRIFT_ADD_COMPILER(javame "Enable compiler for Java ME" ON)
THRIFT_ADD_COMPILER(js "Enable compiler for JavaScript" ON)
THRIFT_ADD_COMPILER(json "Enable compiler for JSON" ON)
+THRIFT_ADD_COMPILER(kotlin "Enable compiler for Kotlin" ON)
THRIFT_ADD_COMPILER(lua "Enable compiler for Lua" ON)
THRIFT_ADD_COMPILER(netstd "Enable compiler for .NET Standard" ON)
THRIFT_ADD_COMPILER(ocaml "Enable compiler for OCaml" ON)