summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2019-10-19 21:22:59 +0200
committerJens Geyer <jensg@apache.org>2019-10-20 16:20:57 +0200
commit7199741f440ef7de15e13755ea2371157c8cd298 (patch)
tree760ba3ff7a69d96dd6b05214e18c2d0ddc51ec06 /compiler/cpp/CMakeLists.txt
parent616df98f00a594f133466aa7f94930c1bf85b24a (diff)
downloadthrift-7199741f440ef7de15e13755ea2371157c8cd298.tar.gz
THRIFT-4938 Issues with version.h treatment
Client: Compiler Patch: Jens Geyer This closes #1902
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index 17dae4787..2bc08cfa6 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -20,7 +20,8 @@
cmake_minimum_required(VERSION 3.3)
project("thrift-compiler" VERSION ${PACKAGE_VERSION})
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/thrift/version.h.in ${CMAKE_CURRENT_BINARY_DIR}/thrift/version.h)
+# version.h now handled via veralign.sh
+#configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/thrift/version.h.in ${CMAKE_CURRENT_BINARY_DIR}/thrift/version.h)
find_package(FLEX REQUIRED)
find_package(BISON REQUIRED)
@@ -47,7 +48,7 @@ set(compiler_core
src/thrift/generate/t_generator.cc
src/thrift/parse/t_typedef.cc
src/thrift/parse/parse.cc
- ${CMAKE_CURRENT_BINARY_DIR}/thrift/version.h
+ src/thrift/version.h
)
set(thrift-compiler_SOURCES