summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen George <allen.george@gmail.com>2016-11-02 08:01:08 -0400
committerJens Geyer <jensg@apache.org>2017-01-26 01:34:16 +0100
commit8b96bfbf1eb058d3c378535e90c1e90280224bb4 (patch)
tree9b7719c1bb205f7132f4b1870f974c6ceb7f0bac /compiler/cpp/CMakeLists.txt
parent6fe7fa1b7ed72215a59e93c680a209a99530fada (diff)
downloadthrift-8b96bfbf1eb058d3c378535e90c1e90280224bb4.tar.gz
THRIFT-2945 Add Rust support
Client: Rust Patch: Allen George <allen.george@gmail.com> This closes #1147
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index 9f7585d78..8e861e41c 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -101,6 +101,7 @@ THRIFT_ADD_COMPILER(go "Enable compiler for Go" ON)
THRIFT_ADD_COMPILER(d "Enable compiler for D" ON)
THRIFT_ADD_COMPILER(lua "Enable compiler for Lua" ON)
THRIFT_ADD_COMPILER(gv "Enable compiler for GraphViz" ON)
+THRIFT_ADD_COMPILER(rs "Enable compiler for Rust" ON)
THRIFT_ADD_COMPILER(xml "Enable compiler for XML" ON)
# Thrift is looking for include files in the src directory