summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorMark Erickson <mark.erickson@workiva.com>2015-08-29 10:46:51 -0500
committerJens Geyer <jensg@apache.org>2015-10-03 01:43:59 +0200
commit932c4700c6e3aee20b74d5e2f562326029e6b9c8 (patch)
tree9e701dff2cf2726c2ab2af75c72dce4e8fc9ea89 /compiler/cpp/CMakeLists.txt
parent123258ba60facd8581d868c71a543487b2acff3c (diff)
downloadthrift-932c4700c6e3aee20b74d5e2f562326029e6b9c8.tar.gz
THRIFT-3299 Create an Apache Thrift language binding for Dart (dartlang.org).
Client: Dart Patch: Mark Erickson <mark.erickson@workiva.com> This closes #608
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index bc6591ca8..2d0c3f08b 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -47,7 +47,7 @@ set(libparse_SOURCES
add_library(libparse STATIC ${libparse_SOURCES})
# Create the thrift compiler
-set( thrift_SOURCES
+set( thrift_SOURCES
src/main.cc
src/md5.c
src/generate/t_generator.cc
@@ -100,6 +100,7 @@ THRIFT_ADD_COMPILER(c_glib "Enable compiler for C with Glib" ON)
THRIFT_ADD_COMPILER(cpp "Enable compiler for C++" ON)
THRIFT_ADD_COMPILER(java "Enable compiler for Java" ON)
THRIFT_ADD_COMPILER(as3 "Enable compiler for ActionScript 3" ON)
+THRIFT_ADD_COMPILER(dart "Enable compiler for Dart" ON)
THRIFT_ADD_COMPILER(haxe "Enable compiler for Haxe" ON)
THRIFT_ADD_COMPILER(csharp "Enable compiler for C#" ON)
THRIFT_ADD_COMPILER(py "Enable compiler for Python 2.0" ON)