summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsuke@apache.org>2016-10-02 14:21:55 +0900
committerNobuaki Sukegawa <nsuke@apache.org>2016-10-03 00:57:41 +0900
commitd8c6a84866f7afb3ef9bb8f1d74fe1984b873d98 (patch)
tree606960472ed7b6ec4d5d94ec766cadcca2e949e2 /compiler/cpp/CMakeLists.txt
parent3129549feb1647a42c5e29f4ac171583937139fa (diff)
downloadthrift-d8c6a84866f7afb3ef9bb8f1d74fe1984b873d98.tar.gz
THRIFT-3940 Visual Studio project file for compiler is broken
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt15
1 files changed, 2 insertions, 13 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index 2d9529a8f..02ed78c64 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -17,12 +17,7 @@
# under the License.
#
-# Windows has a different header
-if(MSVC)
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/thrift/windows/version.h.in ${CMAKE_CURRENT_BINARY_DIR}/thrift/version.h)
-else()
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/thrift/version.h.in ${CMAKE_CURRENT_BINARY_DIR}/thrift/version.h)
-endif()
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/thrift/version.h.in ${CMAKE_CURRENT_BINARY_DIR}/thrift/version.h)
find_package(FLEX REQUIRED)
find_package(BISON REQUIRED)
@@ -163,6 +158,7 @@ if(${WITH_PLUGIN})
"src/thrift/logging.h"
"src/thrift/main.h"
"src/thrift/platform.h"
+ "${CMAKE_BINARY_DIR}/compiler/cpp/thrift/version.h"
DESTINATION "${INCLUDE_INSTALL_DIR}/thrift")
install(FILES
"src/thrift/audit/t_audit.h"
@@ -202,13 +198,6 @@ if(MSVC)
install(FILES
"src/thrift/windows/config.h"
DESTINATION "${INCLUDE_INSTALL_DIR}/thrift/windows")
- install(FILES
- "${CMAKE_BINARY_DIR}/compiler/cpp/thrift/windows/version.h"
- DESTINATION "${INCLUDE_INSTALL_DIR}/thrift/windows")
-else()
- install(FILES
- "${CMAKE_BINARY_DIR}/compiler/cpp/thrift/version.h"
- DESTINATION "${INCLUDE_INSTALL_DIR}/thrift")
endif()
endif()