summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJake Farrell <jfarrell@apache.org>2011-05-05 13:45:26 +0000
committerJake Farrell <jfarrell@apache.org>2011-05-05 13:45:26 +0000
commit05e0cdb4542b9ae0c3db0d841004b4acc1a73033 (patch)
treef8d1e85da220a0097c5b825764c9ab0531859fa7 /configure.ac
parentb34b83e89d678b5d3ed1a91c2c9071fbb75c6b31 (diff)
downloadthrift-05e0cdb4542b9ae0c3db0d841004b4acc1a73033.tar.gz
Thrift-1104: INSTALLDIRS should be included in configure script
Client: perl, build process Patch: Dmitriy Kargapolov Adds INSTALLDIRS to configure to be able to specify a specific install location for perl since it does not use --prefix. git-svn-id: https://svn.apache.org/repos/asf/thrift/trunk@1099799 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 82318ad75..faffa5581 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,9 +56,16 @@ AC_ARG_VAR([PHP_CONFIG_PREFIX],
Default = "/etc/php.d"])
AS_IF([test "x$PHP_CONFIG_PREFIX" = x], [PHP_CONFIG_PREFIX="/etc/php.d"])
+AC_ARG_VAR([INSTALLDIRS], [When installing Perl modules, specifies which
+ of the sets of installation directories
+ to choose: perl, site or vendor.
+ Default = "vendor"])
+AS_IF([test "x$INSTALLDIRS" = x], [INSTALLDIRS="vendor"])
+
AC_ARG_VAR([PERL_PREFIX], [Prefix for installing Perl modules.
(Normal --prefix is ignored for Perl because
Perl has different conventions.)
+ Ignored, when INSTALLDIRS set to site or vendor.
Default = "/usr/local/lib"])
AS_IF([test "x$PERL_PREFIX" = x], [PERL_PREFIX="/usr/local"])