summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames E. King, III <jking@apache.org>2017-02-13 15:25:41 -0500
committerJames E. King, III <jking@apache.org>2017-02-13 15:25:41 -0500
commit36628a28e975e4d680fff66eec3e66c06ca86bf2 (patch)
tree2f9a1c99bd6212c6db636671c4d6c788cdd20b47 /configure.ac
parente8ba7877baec6f9871a88db8d3885361a2260ab2 (diff)
downloadthrift-36628a28e975e4d680fff66eec3e66c06ca86bf2.tar.gz
THRIFT-3369 Provide SSL/TLS client for c_glib
Client: c_glib Patch: Gonzalo Aguilar Delgado <gaguilar@level2crm.com> This closes #1185
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8a15ede26..09c6d9e2d 100755
--- a/configure.ac
+++ b/configure.ac
@@ -132,7 +132,6 @@ if test "$enable_libs" = "no"; then
with_rs="no"
fi
-
AX_THRIFT_LIB(cpp, [C++], yes)
have_cpp=no
if test "$with_cpp" = "yes"; then
@@ -147,8 +146,6 @@ if test "$with_cpp" = "yes"; then
have_cpp="yes"
fi
- AX_CHECK_OPENSSL()
-
AX_LIB_EVENT([1.0])
have_libevent=$success
@@ -199,6 +196,12 @@ if test "$with_c_glib" = "yes"; then
fi
AM_CONDITIONAL(WITH_C_GLIB, [test "$have_glib2" = "yes" -a "$have_gobject2" = "yes"])
+echo "OpenSSL check"
+if test "$have_cpp" = "yes" -o "$have_c_glib" = "yes"; then
+ echo "Have cpp or c so we check for OpenSSL"
+ AX_CHECK_OPENSSL()
+fi
+
AX_THRIFT_LIB(csharp, [C#], yes)
if test "$with_csharp" = "yes"; then
PKG_CHECK_MODULES(MONO, mono >= 2.11.0, mono_2_11=yes, mono_2_11=no)