summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2020-02-22 16:51:51 +0100
committerJens Geyer <jensg@apache.org>2020-02-28 19:18:34 +0100
commit56700e469d5d0659994a3963ad5a111740cf8277 (patch)
treedb903818e332aa6887f2efd2797163ffa4268d67 /configure.ac
parent4903d18fca988871bcedce3b420fef2cd9682ca1 (diff)
downloadthrift-56700e469d5d0659994a3963ad5a111740cf8277.tar.gz
THRIFT-4982 Remove deprecated C# bindings from the code base
Client: csharp Patch: Jens Geyer This closes #2027
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac31
1 files changed, 0 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index f3f88a715..99c3c9cd7 100755
--- a/configure.ac
+++ b/configure.ac
@@ -121,7 +121,6 @@ if test "$enable_libs" = "no"; then
with_c_glib="no"
with_cl="no"
with_java="no"
- with_csharp="no"
with_python="no"
with_py3="no"
with_ruby="no"
@@ -212,24 +211,6 @@ if test "$have_cpp" = "yes" -o "$have_c_glib" = "yes"; then
AX_CHECK_OPENSSL()
fi
-AX_THRIFT_LIB(csharp, [C#], yes)
-if test "$with_csharp" = "yes"; then
- PKG_CHECK_MODULES(MONO, mono >= 2.11.0, mono_2_11=yes, mono_2_11=no)
- if test "$mono_2_11" == "yes"; then
- AC_PATH_PROG([MCS], [mcs])
- if test "x$MCS" != "x"; then
- mono_mcs="yes"
- fi
- fi
- PKG_CHECK_MODULES(MONO, mono >= 2.0.0, net_3_5=yes, net_3_5=no)
- PKG_CHECK_MODULES(MONO, mono >= 1.2.4, have_mono=yes, have_mono=no)
- if test "$have_mono" = "yes" ; then
- have_csharp="yes"
- fi
-fi
-AM_CONDITIONAL(WITH_MONO, [test "$have_csharp" = "yes"])
-AM_CONDITIONAL(NET_2_0, [test "$net_3_5" = "no"])
-AM_CONDITIONAL(MONO_MCS, [test "$mono_mcs" = "yes"])
AX_THRIFT_LIB(java, [Java], yes)
if test "$with_java" = "yes"; then
@@ -802,8 +783,6 @@ AC_CONFIG_FILES([
lib/c_glib/Makefile
lib/c_glib/thrift_c_glib.pc
lib/c_glib/test/Makefile
- lib/csharp/Makefile
- lib/csharp/test/Multiplex/Makefile
lib/d/Makefile
lib/d/test/Makefile
lib/erl/Makefile
@@ -838,7 +817,6 @@ AC_CONFIG_FILES([
test/c_glib/Makefile
test/cl/Makefile
test/cpp/Makefile
- test/csharp/Makefile
test/erl/Makefile
test/go/Makefile
test/haxe/Makefile
@@ -885,8 +863,6 @@ if test "$have_d" = "yes" -a "$have_deimos_event2" = "yes" -a "$have_deimos_open
AC_SUBST([MAYBE_D])
if test "$have_java" = "yes" ; then MAYBE_JAVA="java" ; else MAYBE_JAVA="" ; fi
AC_SUBST([MAYBE_JAVA])
-if test "$have_csharp" = "yes" ; then MAYBE_CSHARP="csharp" ; else MAYBE_CSHARP="" ; fi
-AC_SUBST([MAYBE_CSHARP])
if test "$have_python" = "yes" ; then MAYBE_PYTHON="py" ; else MAYBE_PYTHON="" ; fi
AC_SUBST([MAYBE_PYTHON])
if test "$have_py3" = "yes" ; then MAYBE_PY3="py3" ; else MAYBE_PY3="" ; fi
@@ -928,7 +904,6 @@ echo "$PACKAGE $VERSION"
echo
echo "Building ActionScript3 Library : $have_as3"
echo "Building C (GLib) Library .... : $have_c_glib"
-echo "Building C# (Mono) Library ... : $have_csharp"
echo "Building C++ Library ......... : $have_cpp"
echo "Building Common Lisp Library.. : $have_cl"
echo "Building D Library ........... : $have_d"
@@ -960,12 +935,6 @@ if test "$have_c_glib" = "yes" ; then
echo "C (glib):"
echo " Using glib version ........ : $($GSETTINGS --version)"
fi
-if test "$have_csharp" = "yes" ; then
- echo
- echo "C# Library:"
- echo " Using .NET 3.5 ............ : $net_3_5"
- echo " Using mono version ........ : $($MCS --version | head -1)"
-fi
if test "$have_cpp" = "yes" ; then
echo
echo "C++ Library:"