summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2021-03-20 18:07:17 +0100
committerJens Geyer <jensg@apache.org>2021-03-22 09:42:38 +0100
commit66d897667c451ef6560d89b979b7001c57a3eda6 (patch)
tree4420429109c582375fc68aa125a2b6f6b8019dd3 /configure.ac
parentcd2fae091b9bafd0977ef290f722532c36a64d2e (diff)
downloadthrift-66d897667c451ef6560d89b979b7001c57a3eda6.tar.gz
THRIFT-5347 Remove deprecated Haskell bindings
Client: hs Patch: Jens Geyer This closes #2352
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 2d6d62ba2..6c9cfca58 100755
--- a/configure.ac
+++ b/configure.ac
@@ -70,12 +70,6 @@ AC_ARG_VAR([PERL_PREFIX], [Prefix for installing Perl modules.
Default = "/usr/local/lib"])
AS_IF([test "x$PERL_PREFIX" = x], [PERL_PREFIX="/usr/local"])
-AC_ARG_VAR([CABAL_CONFIGURE_FLAGS],
- [Extra flags to pass to cabal: "cabal Setup.lhs configure $CABAL_CONFIGURE_FLAGS".
- (Typically used to set --user or force --global.)])
-
-AC_SUBST(CABAL_CONFIGURE_FLAGS)
-
AC_ARG_VAR([D_IMPORT_PREFIX], [Prefix for installing D modules.
[INCLUDEDIR/d2]])
AS_IF([test "x$D_IMPORT_PREFIX" = x], [D_IMPORT_PREFIX="${includedir}/d2"])
@@ -123,7 +117,6 @@ if test "$enable_libs" = "no"; then
with_python="no"
with_py3="no"
with_ruby="no"
- with_haskell="no"
with_haxe="no"
with_netstd="no"
with_perl="no"
@@ -366,24 +359,6 @@ fi
AM_CONDITIONAL(WITH_RUBY, [test "$have_ruby" = "yes"])
AM_CONDITIONAL(HAVE_BUNDLER, [test "x$BUNDLER" != "x"])
-AX_THRIFT_LIB(haskell, [Haskell], yes)
-have_haskell=no
-RUNHASKELL=true
-CABAL=true
-if test "$with_haskell" = "yes"; then
- AC_PATH_PROG([CABAL], [cabal])
- AC_PATH_PROG([RUNHASKELL], [runhaskell])
- if test "x$CABAL" != "x" -a "x$RUNHASKELL" != "x"; then
- have_haskell="yes"
- else
- RUNHASKELL=true
- CABAL=true
- fi
-fi
-AC_SUBST(CABAL)
-AC_SUBST(RUNHASKELL)
-AM_CONDITIONAL(WITH_HASKELL, [test "$have_haskell" = "yes"])
-
AX_THRIFT_LIB(go, [Go], yes)
if test "$with_go" = "yes"; then
AC_PATH_PROG([GO], [go])
@@ -779,7 +754,6 @@ AC_CONFIG_FILES([
lib/go/Makefile
lib/go/test/Makefile
lib/haxe/test/Makefile
- lib/hs/Makefile
lib/java/Makefile
lib/js/Makefile
lib/js/test/Makefile
@@ -816,7 +790,6 @@ AC_CONFIG_FILES([
test/erl/Makefile
test/go/Makefile
test/haxe/Makefile
- test/hs/Makefile
test/lua/Makefile
test/netstd/Makefile
test/php/Makefile
@@ -834,7 +807,6 @@ AC_CONFIG_FILES([
tutorial/d/Makefile
tutorial/go/Makefile
tutorial/haxe/Makefile
- tutorial/hs/Makefile
tutorial/java/Makefile
tutorial/js/Makefile
tutorial/netstd/Makefile
@@ -863,8 +835,6 @@ if test "$have_py3" = "yes" ; then MAYBE_PY3="py3" ; else MAYBE_PY3="" ; fi
AC_SUBST([MAYBE_PY3])
if test "$have_ruby" = "yes" ; then MAYBE_RUBY="rb" ; else MAYBE_RUBY="" ; fi
AC_SUBST([MAYBE_RUBY])
-if test "$have_haskell" = "yes" ; then MAYBE_HASKELL="hs" ; else MAYBE_HASKELL="" ; fi
-AC_SUBST([MAYBE_HASKELL])
if test "$have_perl" = "yes" ; then MAYBE_PERL="perl" ; else MAYBE_PERL="" ; fi
AC_SUBST([MAYBE_PERL])
if test "$have_php" = "yes" ; then MAYBE_PHP="php" ; else MAYBE_PHP="" ; fi
@@ -904,7 +874,6 @@ echo "Building Dart Library ........ : $have_dart"
echo "Building .NET Standard Library : $have_netstd"
echo "Building Erlang Library ...... : $have_erlang"
echo "Building Go Library .......... : $have_go"
-echo "Building Haskell Library ..... : $have_haskell"
echo "Building Haxe Library ........ : $have_haxe"
echo "Building Java Library ........ : $have_java"
echo "Building Lua Library ......... : $have_lua"
@@ -971,13 +940,6 @@ if test "$have_go" = "yes" ; then
echo " Using Go................... : $GO"
echo " Using Go version........... : $($GO version)"
fi
-if test "$have_haskell" = "yes" ; then
- echo
- echo "Haskell Library:"
- echo " Using Cabal ............... : $CABAL"
- echo " Using Haskell ............. : $RUNHASKELL"
- echo " Using Haskell version ..... : $($RUNHASKELL --version)"
-fi
if test "$have_haxe" = "yes" ; then
echo
echo "Haxe Library:"