summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Erickson <mark.erickson@workiva.com>2015-08-29 10:46:51 -0500
committerJens Geyer <jensg@apache.org>2015-10-03 01:43:59 +0200
commit932c4700c6e3aee20b74d5e2f562326029e6b9c8 (patch)
tree9e701dff2cf2726c2ab2af75c72dce4e8fc9ea89 /configure.ac
parent123258ba60facd8581d868c71a543487b2acff3c (diff)
downloadthrift-932c4700c6e3aee20b74d5e2f562326029e6b9c8.tar.gz
THRIFT-3299 Create an Apache Thrift language binding for Dart (dartlang.org).
Client: Dart Patch: Mark Erickson <mark.erickson@workiva.com> This closes #608
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 880cc3225..e6b3be0e6 100755
--- a/configure.ac
+++ b/configure.ac
@@ -122,6 +122,7 @@ if test "$enable_libs" = "no"; then
with_perl="no"
with_php="no"
with_php_extension="no"
+ with_dart="no"
with_erlang="no"
with_go="no"
with_d="no"
@@ -325,6 +326,16 @@ AM_CONDITIONAL(WITH_PHP_EXTENSION, [test "$have_php_extension" = "yes"])
AC_PATH_PROG([PHPUNIT], [phpunit])
AM_CONDITIONAL(HAVE_PHPUNIT, [test "x$PHPUNIT" != "x"])
+AX_THRIFT_LIB(dart, [DART], yes)
+if test "$with_dart" = "yes"; then
+ AC_PATH_PROG([DART], [dart])
+ AC_PATH_PROG([DARTPUB], [pub])
+ if test "x$DART" != "x" -a "x$DARTPUB" != "x"; then
+ have_dart="yes"
+ fi
+fi
+AM_CONDITIONAL(WITH_DART, [test "$have_dart" = "yes"])
+
AX_THRIFT_LIB(ruby, [Ruby], yes)
have_ruby=no
if test "$with_ruby" = "yes"; then
@@ -727,6 +738,7 @@ AC_CONFIG_FILES([
lib/perl/test/Makefile
lib/php/Makefile
lib/php/test/Makefile
+ lib/dart/Makefile
lib/py/Makefile
lib/rb/Makefile
lib/lua/Makefile
@@ -738,6 +750,7 @@ AC_CONFIG_FILES([
test/haxe/Makefile
test/hs/Makefile
test/php/Makefile
+ test/dart/Makefile
test/perl/Makefile
test/py/Makefile
test/py.twisted/Makefile
@@ -752,6 +765,7 @@ AC_CONFIG_FILES([
tutorial/java/Makefile
tutorial/js/Makefile
tutorial/nodejs/Makefile
+ tutorial/dart/Makefile
tutorial/py/Makefile
tutorial/py.twisted/Makefile
tutorial/py.tornado/Makefile
@@ -776,6 +790,8 @@ if test "$have_perl" = "yes" ; then MAYBE_PERL="perl" ; else MAYBE_PERL="" ; fi
AC_SUBST([MAYBE_PERL])
if test "$have_php" = "yes" ; then MAYBE_PHP="php" ; else MAYBE_PHP="" ; fi
AC_SUBST([MAYBE_PHP])
+if test "$have_dart" = "yes" ; then MAYBE_DART="dart" ; else MAYBE_DART="" ; fi
+AC_SUBST([MAYBE_DART])
if test "$have_go" = "yes" ; then MAYBE_GO="go" ; else MAYBE_GO="" ; fi
AC_SUBST([MAYBE_GO])
if test "$have_nodejs" = "yes" ; then MAYBE_NODEJS="nodejs" ; else MAYBE_NODEJS="" ; fi
@@ -797,6 +813,7 @@ echo "Building Haxe Library ........ : $have_haxe"
echo "Building Haskell Library ..... : $have_haskell"
echo "Building Perl Library ........ : $have_perl"
echo "Building PHP Library ......... : $have_php"
+echo "Building Dart Library ........ : $have_dart"
echo "Building Erlang Library ...... : $have_erlang"
echo "Building Go Library .......... : $have_go"
echo "Building D Library ........... : $have_d"
@@ -834,6 +851,12 @@ if test "$have_php" = "yes" ; then
echo "PHP Library:"
echo " Using php-config .......... : $PHP_CONFIG"
fi
+if test "$have_dart" = "yes" ; then
+ echo
+ echo "Dart Library:"
+ echo " Using Dart ................ : $DART"
+ echo " Using Pub ................. : $DARTPUB"
+fi
if test "$have_ruby" = "yes" ; then
echo
echo "Ruby Library:"