summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2019-01-28 23:27:45 +0100
committerJens Geyer <jensg@apache.org>2019-01-28 23:12:28 +0100
commitaa0c8b35d8f78812de1d7803d6277a37d2ed593a (patch)
treeb71ac06b6da5c135b11aea72bf12207e9cce0c2b /configure.ac
parent1231930abd1d72b422deec967559caf3dc02dac7 (diff)
downloadthrift-aa0c8b35d8f78812de1d7803d6277a37d2ed593a.tar.gz
THRIFT-4723 Consolidate C#/netcore into new netstd language target
Client: netstd Patch: Jens Geyer This closes #1710
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7da52a0bf..b09c98361 100755
--- a/configure.ac
+++ b/configure.ac
@@ -128,6 +128,7 @@ if test "$enable_libs" = "no"; then
with_haskell="no"
with_haxe="no"
with_dotnetcore="no"
+ with_netstd="no"
with_perl="no"
with_php="no"
with_php_extension="no"
@@ -508,7 +509,7 @@ if test "$with_dotnetcore" = "yes"; then
AX_PROG_DOTNETCORE_VERSION( [2.0.0], have_dotnetcore="yes", have_dotnetcore="no")
fi
fi
-AM_CONDITIONAL(WITH_DOTNETCORE, [test "$have_dotnetcore" = "yes"])
+AM_CONDITIONAL(WITH_DOTNET, [test "$have_dotnetcore" = "yes"])
AX_THRIFT_LIB(d, [D], yes)
@@ -818,6 +819,7 @@ AC_CONFIG_FILES([
lib/json/Makefile
lib/json/test/Makefile
lib/netcore/Makefile
+ lib/netstd/Makefile
lib/nodejs/Makefile
lib/nodets/Makefile
lib/perl/Makefile
@@ -846,6 +848,7 @@ AC_CONFIG_FILES([
test/hs/Makefile
test/lua/Makefile
test/netcore/Makefile
+ test/netstd/Makefile
test/php/Makefile
test/dart/Makefile
test/perl/Makefile
@@ -865,6 +868,7 @@ AC_CONFIG_FILES([
tutorial/java/Makefile
tutorial/js/Makefile
tutorial/netcore/Makefile
+ tutorial/netstd/Makefile
tutorial/nodejs/Makefile
tutorial/dart/Makefile
tutorial/py/Makefile
@@ -933,6 +937,7 @@ echo "Building Common Lisp Library.. : $have_cl"
echo "Building D Library ........... : $have_d"
echo "Building Dart Library ........ : $have_dart"
echo "Building dotnetcore Library .. : $have_dotnetcore"
+echo "Building .NET Standard Library : $have_dotnetcore"
echo "Building Erlang Library ...... : $have_erlang"
echo "Building Go Library .......... : $have_go"
echo "Building Haskell Library ..... : $have_haskell"
@@ -1001,6 +1006,12 @@ if test "$have_dotnetcore" = "yes" ; then
echo " Using .NET Core ........... : $DOTNETCORE"
echo " Using .NET Core version ... : $DOTNETCORE_VERSION"
fi
+if test "$have_dotnetcore" = "yes" ; then
+ echo
+ echo ".NET Standard Library:"
+ echo " Using dotnet .............. : $DOTNETCORE"
+ echo " Using dotnet version ...... : $DOTNETCORE_VERSION"
+fi
if test "$have_erlang" = "yes" ; then
echo
echo "Erlang Library:"